[aerogear-dev] iOS API overhaul - rename 'getter' for 'modules'

Christos Vasilakis cvasilak at gmail.com
Thu Dec 20 08:16:43 EST 2012


Hi team,

as part of the API overhaul ticket[1] for the next CR1 release, inside of the following classes we have a getter, to get an actual object by its name:
	• AGPipeline
	• AGDataManager
	• AGAuthenticator 

Example
- (id<AGAuthenticationModule>)get:(NSString *)moduleName

In in the iOS land, a get* method by convention is used to fill the parameters of the method with a value, for example see [2] from apple documentation . What we propose is a rename of these methods,  for example:

- (id<AGAuthenticationModule>)moduleWithName:(NSString *)moduleName

What do you think?

A ticket has been already opened for this change, see [3]

Thanks,
Christos


[1] https://issues.jboss.org/browse/AEROGEAR-763
[2] https://developer.apple.com/library/mac/documentation/Cocoa/Reference/ApplicationKit/Classes/NSColor_Class/Reference/Reference.html#//apple_ref/occ/instm/NSColor/getCyan:magenta:yellow:black:alpha:
[3] https://issues.jboss.org/browse/AEROGEAR-767




More information about the aerogear-dev mailing list