[aerogear-dev] pushplugin release

Stefan Miklosovic smikloso at redhat.com
Wed May 7 10:38:36 EDT 2014


regarding of a release, I looked at it little bit closer and these are my findings.

I tried latest master with cordova plugin add https://github.com/aerogear/aerogear-pushplugin-cordova and 
I tried it on this demo (1)

1) What does not work

a) Android 2.3.3 emulator with Google API + mentioned demo, whole app crashes upon its start like (2)
b) Android 2.3.4 physical device (My Sony Ericsson with Android 2.3.4) - it shows this weird dialog (3)
c) Android 4.1.2 physical device (Samsung) - same as (3) however once it shows it and once not ... it is not deterministic

Regarding of (3), even I cancel it, it just freezes and does nothing.

2) What works by automatic test but not deterministically

Android 4.4.2 emulator + Google API 

This is little bit more complicated. Droidium can test in a such way that in case AVD of your emulator is not 
present on your machine, that AVD is automatically created in test execution itself and emulator is booted, 
APK is deployed there tests are carried out and emulator is dynamically deleted when test stops.

Even emulator is booted and APK is installed there and test proceeds, in the background Google GCM service seems 
to be not initialized in time we are sending a message so it is kind of not delivered. By debugging it step-by-step
it seems it has enough time to initialize itself.

However, the same issue with a message being not delivered has occured at fully prepared emulator as well.

3) What works manually

Android 4.4.2 emulator + Google API meaning without test but buy sending a message from web admin of (4)


1) For testing purposes we have this UPS installation (4) and while I was coping with this testing manually, 
when I sent some message from UPS web admin, it appeared on emulator twice, so it was basically sent two times. Any explanation for this?

2) Sometime that message was not delivered to emulator at all, meaning even I send it from test it has not appeared on emulator. By accident 
this was resolved when I refreshed web admin in browser. I do not know if this is somehow related but why not ...

I used this test (5) which uses Arquillian Droidium. Test is pretty straightforward and if you know some Selenium you are already done.

(1) https://github.com/aerogear/aerogear-push-helloworld/tree/master/cordova
(2) http://pastebin.com/raw.php?i=CLrR07mH
(3) http://devio.us/~stewe/DSC_0164.JPG
(4) https://cordovaci-mobileqa.rhcloud.com
(5) https://github.com/smiklosovic/cordova-pushplugin-test-/blob/master/src/test/java/org/jboss/aerogear/push/plugin/cordova/AeroGearPushPluginCordovaTestCase.java

Stefan Miklosovic
Red Hat Brno - JBoss Mobile Platform

e-mail: smikloso at redhat.com
irc: smikloso

----- Original Message -----
> Hi,
> I’ve announced it before, but didn’t came around to actually do it and we
> started discussing the version number. So end of the week I’ll release a new
> version of the aerogear-pushplugin-cordova (for real this time) with version
> 0.5.0 this will include the 64 bit support the new API and some small bug
> fixes.
> Cheers,
> 	Erik Jan
> _______________________________________________
> aerogear-dev mailing list
> aerogear-dev at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/aerogear-dev

More information about the aerogear-dev mailing list