[arquillian-issues] [JBoss JIRA] Commented: (ARQ-389) Rename @Target, @Expected, @Run and @DeploymentTarget annotations

Aslak Knutsen (JIRA) jira-events at lists.jboss.org
Thu Mar 17 08:26:46 EDT 2011


    [ https://issues.jboss.org/browse/ARQ-389?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12588592#comment-12588592 ] 

Aslak Knutsen commented on ARQ-389:
-----------------------------------

@Deployment.startup renamed managed, to avoid changing boolean logic.

@Protocol renamed @OverProtocol

{code}
@Deployment @TargetsContainer("active-1") @OverProtocol("Servlet 3.0")
public void WebArchive myComponent() 
{
   return ShrinkWrap.create(WebArchive.class);
}
{code}

> Rename @Target, @Expected, @Run and @DeploymentTarget annotations
> -----------------------------------------------------------------
>
>                 Key: ARQ-389
>                 URL: https://issues.jboss.org/browse/ARQ-389
>             Project: Arquillian
>          Issue Type: Feature Request
>          Components: Base Implementation
>    Affects Versions: 1.0.0.Alpha4
>            Reporter: Aslak Knutsen
>            Assignee: Aslak Knutsen
>             Fix For: 1.0.0.Alpha5
>
>
> For better consistent naming, we should rename the API annotations:
> * @Run(RunModeType) = @RunAsClient
> ** InContainer is extracted from @Deployment(testable) and only possible to override with AS_CLIENT
> * @Expected = @ShouldThrowException
> * @Target = @TargetsContainer("x")
> ** Clearify meaning
> * @DeploymentTarget = @OperateOnDeployment
> ** Clearify that this test will operate within the context of the @Deployment
> {code}
> public class TestClass
> {
> 	@Deployment(name = "dep", testable=false) @ShouldThrowException(Exception.class) @TargetsContainer("x")
> 	public JavaArchive create() {}
> container x{
> 	deployment dep{
> 	@Test @RunAsClient @OperateOnDeployment("dep") 
> 	public void shouldBe() {}
> container x{
> 	
> 	@Test @OperateOnContainer("x")
> 	public void shouldBe() {}
> 	
> }
> {code}

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the arquillian-issues mailing list