[bv-dev] @Past(orPresent=true) -> @PastOrPresent?
gunnar at hibernate.org
Wed Jun 21 05:50:25 EDT 2017
A colleague of mine reviewing the BV 2.0 changes pointed out an
inconsistency in the added/modified constraints.
As per the community poll we have now @NegativeOrZero and
@PositiveOrZero, whereas we still have the orPresent() option on @Past
and @Future. Should it be @PastOrPresent and @FutureOrPresent instead
for the sake of consistency?
Now one could argue that having only attributes (orPresent(),
orZero()) is most consistent with other constraints such as
@DigitalMin. But indeed the explicit annotations grew on me over time
as they are a bit shorter to use and, more importantly, better to
It's late in the game, but I feel inclined to extract @PastOrPresent
and @FutureOrPresent. What do you think?
More information about the beanvalidation-dev