[bv-dev] Support for OptionalInt, OptionalLong and OptionalDouble
emmanuel at hibernate.org
Thu May 18 02:45:21 EDT 2017
On 17 May 2017, at 15:33, Gunnar Morling <gunnar at hibernate.org> wrote:
>> Should we be really brave and rename or alias that member to value()?
> I thought about it, but value() reads poorly if other members are
> added down the road (I cannot think of any, though). But given that
> @ExtractedValue is only used by BV providers and a very few authors of
> custom extractors, I don't mind the few extra characters of type() for
> the sake of more explicitness.
> What do others think?
Even if type is the only attribute ever, I think it is much clearer than value. I'd keep it as is.
More information about the beanvalidation-dev