<div dir="ltr">&gt; <span style="font-family:arial,sans-serif;font-size:13px">I know executables might be the </span><span style="font-family:arial,sans-serif;font-size:13px">right name now, but it always has the long standing meaning of binary executables which might get you confused when </span><span style="font-family:arial,sans-serif;font-size:13px">reading the method name.</span><div>
<span style="font-family:arial,sans-serif;font-size:13px"><br></span></div><div style><span style="font-family:arial,sans-serif;font-size:13px">I can see your point about mixing this up with binary executables, but OTOH I&#39;d expect people to get more and more used to applying the term to methods/constructors, given that it is also used in the JDK 8 with that meaning. The JavaDoc further clarifies forExecutables()&#39;s purpose.</span></div>
<div style><span style="font-family:arial,sans-serif;font-size:13px"><br></span></div><div style><span style="font-family:arial,sans-serif;font-size:13px">&gt; </span><span style="font-family:arial,sans-serif;font-size:13px">If we rename the API we really should rename the whole feature and call it &quot;Executable validation&quot;. Do we want to go this far?</span></div>
<div style><span style="font-family:arial,sans-serif;font-size:13px"><br></span></div><div style><span style="font-family:arial,sans-serif;font-size:13px">Hmmm, I think this would be indeed a step too far.</span></div><div style>
<span style="font-family:arial,sans-serif;font-size:13px"><br></span></div><div style><span style="font-family:arial,sans-serif;font-size:13px">IMO the general concept and its manifestation in method/type identifiers don&#39;t have to match 100%. In some cases we speak about &quot;method and constructor constraints&quot; anyways, and in section 4.5 we also explicitly say &quot;</span>the term &quot;method constraint&quot; refers to
      constraints declared on methods as well as constructors.&quot; So I think we don&#39;t have to adapt the spec wording, but IMO using the correct method/type names would be beneficial for the consistency of the API (which is what most users work with).</div>
<div style><span style="font-family:arial,sans-serif;font-size:13px"><br></span></div><div style><span style="font-family:arial,sans-serif;font-size:13px">--Gunnar</span></div><div style><span style="font-family:arial,sans-serif;font-size:13px"><br>
</span></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">2013/1/8 Hardy Ferentschik <span dir="ltr">&lt;<a href="mailto:hardy@hibernate.org" target="_blank">hardy@hibernate.org</a>&gt;</span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
I have to back up Emmanuel here. &#39;forMethods&#39; resonates much better and I think that just reading this method name<br>
users would have a better idea on what this is about compared to &#39; forExecutables&#39;. I know executables might be the<br>
right name now, but it always has the long standing meaning of binary executables which might get you confused when<br>
reading the method name.<br>
<br>
I have another issue with the renaming. As you know by now I am a big fan consistency, but how far do we want to take it?<br>
If we rename the API we really should rename the whole feature and call it &quot;Executable validation&quot;. Do we want to go this far?<br>
My gut feeling is no in which case I would also recommend to stick to &#39;Validator#forMethods()&#39; in the API.<br>
<span class="HOEnZb"><font color="#888888"><br>
--Hardy<br>
</font></span><div class="HOEnZb"><div class="h5"><br>
<br>
<br>
On 4 Jan 2013, at 11:31 AM, Emmanuel Bernard &lt;<a href="mailto:emmanuel@hibernate.org">emmanuel@hibernate.org</a>&gt; wrote:<br>
<br>
&gt; I like forMethods because it resonates faster on people&#39;s mind. But I<br>
&gt; can live and get forExecutables grow on me. So I&#39;m neutral.<br>
&gt;<br>
&gt; Emmanuel<br>
&gt;<br>
&gt; On Fri 2013-01-04 11:05, Gunnar Morling wrote:<br>
&gt;&gt; Hi all,<br>
&gt;&gt;<br>
&gt;&gt; While working on the TCK, I came across our new method<br>
&gt;&gt; Validator#forMethods() which allows to validate method and constructor<br>
&gt;&gt; parameters/return values.<br>
&gt;&gt;<br>
&gt;&gt; Given that we introduced the term &quot;executable&quot; when referring to both<br>
&gt;&gt; methods and constructors, I wondered whether the method should better be<br>
&gt;&gt; named &quot;forExecutables()&quot;.<br>
&gt;&gt;<br>
&gt;&gt; Thoughts?<br>
&gt;&gt;<br>
&gt;&gt; --Gunnar<br>
&gt;<br>
&gt;&gt; _______________________________________________<br>
&gt;&gt; beanvalidation-dev mailing list<br>
&gt;&gt; <a href="mailto:beanvalidation-dev@lists.jboss.org">beanvalidation-dev@lists.jboss.org</a><br>
&gt;&gt; <a href="https://lists.jboss.org/mailman/listinfo/beanvalidation-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/beanvalidation-dev</a><br>
&gt;<br>
&gt; _______________________________________________<br>
&gt; beanvalidation-dev mailing list<br>
&gt; <a href="mailto:beanvalidation-dev@lists.jboss.org">beanvalidation-dev@lists.jboss.org</a><br>
&gt; <a href="https://lists.jboss.org/mailman/listinfo/beanvalidation-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/beanvalidation-dev</a><br>
<br>
<br>
_______________________________________________<br>
beanvalidation-dev mailing list<br>
<a href="mailto:beanvalidation-dev@lists.jboss.org">beanvalidation-dev@lists.jboss.org</a><br>
<a href="https://lists.jboss.org/mailman/listinfo/beanvalidation-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/beanvalidation-dev</a><br>
</div></div></blockquote></div><br></div>