<div dir="ltr">I am somewhat attracted to Sebastian&#39;s suggestion of illegal identifier characters.  My suggestion would be &quot;&lt;result&gt;&quot;.<br><br>Matt<br></div><div class="gmail_extra"><br><br><div class="gmail_quote">
On Fri, Feb 8, 2013 at 9:21 AM, Hardy Ferentschik <span dir="ltr">&lt;<a href="mailto:hardy@hibernate.org" target="_blank">hardy@hibernate.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
I don&#39;t want to introduce a name for the return value to allow things like<br>
<br>
if(node.getName.equals(&quot;retval&quot;)) {<br>
        ReturnValueDescriptor descriptor = (ReturnValueDescriptor) node.getElementDescriptor();<br>
}<br>
<br>
The actual type of a node is still given by it ElementDescriptor. The name cannot be used for that. It is more for convenience<br>
and &quot;nice&quot; toString implementation. Yes it could be ambiguous, but I don&#39;t think it matters. Any code relying on the property path<br>
as string is potentially wrong anyways. A white space seems odd, especially in the light of toString.<br>
<br>
In that light $retval might be a legal java identifier, but chances are slim someone uses it.<br>
<span class="HOEnZb"><font color="#888888"><br>
--Hardy<br>
</font></span><div class="HOEnZb"><div class="h5"><br>
<br>
On 8 Jan 2013, at 4:07 PM, Sebastian Thomschke &lt;<a href="mailto:sebastian.thomschke@web.de">sebastian.thomschke@web.de</a>&gt; wrote:<br>
<br>
&gt; What if there is a property or method called &quot;returnValue&quot;? I think the constant string returned should contain a character that is not legal for java identifier names. E.g. a white space.<br>
&gt;<br>
&gt; seb<br>
&gt;<br>
&gt; On 08.02.2013 12:51, Gunnar Morling wrote:<br>
&gt;&gt; Experts,<br>
&gt;&gt;<br>
&gt;&gt; another issue where we need some feedback is BVAL-368, which is about the name of path nodes representing return values.<br>
&gt;&gt;<br>
&gt;&gt; As per the current draft, Node#getName() returns null in that case. Question is, whether we should return something more meaningful, and if so, which value.<br>
&gt;&gt;<br>
&gt;&gt; The RI used to return &quot;$retval&quot; before we change this to match the spec. Another obvious option would be &quot;returnValue&quot;. Having a standardized node name for return value nodes would also help with better toString() implementations for j.v.Path (although that&#39;s not standardized).<br>

&gt;&gt;<br>
&gt;&gt; Any thoughts?<br>
&gt;&gt;<br>
&gt;&gt; Thanks,<br>
&gt;&gt;<br>
&gt;&gt; --Gunnar<br>
&gt;&gt;<br>
&gt;&gt; [1] <a href="https://hibernate.onjira.com/browse/BVAL-368" target="_blank">https://hibernate.onjira.com/browse/BVAL-368</a><br>
&gt;&gt;<br>
&gt;&gt;<br>
&gt;&gt; _______________________________________________<br>
&gt;&gt; beanvalidation-dev mailing list<br>
&gt;&gt;<br>
&gt;&gt; <a href="mailto:beanvalidation-dev@lists.jboss.org">beanvalidation-dev@lists.jboss.org</a><br>
&gt;&gt; <a href="https://lists.jboss.org/mailman/listinfo/beanvalidation-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/beanvalidation-dev</a><br>
&gt;<br>
&gt; _______________________________________________<br>
&gt; beanvalidation-dev mailing list<br>
&gt; <a href="mailto:beanvalidation-dev@lists.jboss.org">beanvalidation-dev@lists.jboss.org</a><br>
&gt; <a href="https://lists.jboss.org/mailman/listinfo/beanvalidation-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/beanvalidation-dev</a><br>
<br>
<br>
_______________________________________________<br>
beanvalidation-dev mailing list<br>
<a href="mailto:beanvalidation-dev@lists.jboss.org">beanvalidation-dev@lists.jboss.org</a><br>
<a href="https://lists.jboss.org/mailman/listinfo/beanvalidation-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/beanvalidation-dev</a><br>
</div></div></blockquote></div><br></div>