<div dir="ltr">Hi,<br><div><div class="gmail_extra"><br><div class="gmail_quote">On Wed, Apr 26, 2017 at 10:40 AM, Gunnar Morling <span dir="ltr"><<a href="mailto:gunnar@hibernate.org" target="_blank">gunnar@hibernate.org</a>></span> wrote:<span class="gmail-"></span><br><span class="gmail-"></span><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><span class="gmail-">
> * Should there be a common superinterface for<br>
> Path$[BeanNode|PropertyNode|<wbr>ContainerElementNode], all of which define<br>
> the same methods?<br>
<br>
</span>I've been wondering the same, but come to think that it doesn't give you much.<br>
<br>
You (as a user) are going to work with specific node types (as<br>
narrowed down via getKind() + as()), so I would not expect you to deal<br>
with that super-type in your code. It'd put the declaration of those<br>
methods into one place, which is nice, though I kinda like the<br>
simplicity of the current Node hierarchy, with one specific sub-type<br>
per kind.<br>
<br>
What do others think?<br></blockquote><div><br></div><div>I had the exact same reasoning when I did it.<br></div><div><span class="gmail-"></span><span class="gmail-"></span><br><span class="gmail-"></span></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><span class="gmail-">
> * Should Positive/Negative#strict() default true be provided as<br>
> #orZero() default false, for commonality with<br>
> [Past|Future]#orPresent() ?<br>
<br>
</span>Hum, yes, good point. I think I'd prefer that.<br>
<br>
@Emmanuel, I vaguely remember we discussed this. Did you see a good<br>
reason for the current default?<br>
<br>
@All, what do you think?<br></blockquote><div><br></div><div>Matt, do you just want to change the name or also to change the default?<br><br></div><div>Currently, it's:<br>boolean strict() default false;<br></div><div>and you are supposing the default is true in your question.<br></div><div><br></div><div>Currently, we have:<br></div><div>- Positive/Negative: strict() default false;<br></div><div>- DecimalMin/DecimalMax: inclusive() default true;<br></div><div>- Past/Present: orPresent() default false;<br><br></div><div>I thought about proposing orZero() at the time but I didn't suggest it because "strictly positive" makes sense.<br><br></div><div>Being strict by default would probably make more sense.<br><br></div><div>As for the name, I'm torn.<br><br>-- <br></div><div>Guillaume<br></div></div></div></div></div>