[cdi-dev] [JBoss JIRA] (CDI-288) IdentifiedAnnotatedType.getID() should be called getId()

Jozef Hartinger (JIRA) jira-events at lists.jboss.org
Thu Nov 1 09:29:18 EDT 2012

    [ https://issues.jboss.org/browse/CDI-288?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12730793#comment-12730793 ] 

Jozef Hartinger commented on CDI-288:

Actually, there already is a precedent in CDI:
> IdentifiedAnnotatedType.getID() should be called getId()
> --------------------------------------------------------
>                 Key: CDI-288
>                 URL: https://issues.jboss.org/browse/CDI-288
>             Project: CDI Specification Issues
>          Issue Type: Bug
>          Components: Portable Extensions
>    Affects Versions: 1.1.PRD
>            Reporter: Jozef Hartinger
>            Assignee: Pete Muir
>            Priority: Trivial
>             Fix For: 1.1 (Proposed)
> *getID() vs getId()*
> There is not really a convention we could follow (http://stackoverflow.com/questions/2236807/java-naming-convention-with-acronyms).
> However, there are certain example where the latter option is prefered http://docs.oracle.com/javase/7/docs/api/java/lang/Thread.html#getId()

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

More information about the cdi-dev mailing list