[cdi-dev] [JBoss JIRA] (CDI-288) IdentifiedAnnotatedType.getID() should be called getId()

Pete Muir (JIRA) jira-events at lists.jboss.org
Fri Nov 2 09:01:21 EDT 2012

     [ https://issues.jboss.org/browse/CDI-288?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Pete Muir resolved CDI-288.

    Fix Version/s: 1.1.PFD
                       (was: 1.1 (Proposed))
       Resolution: Done

> IdentifiedAnnotatedType.getID() should be called getId()
> --------------------------------------------------------
>                 Key: CDI-288
>                 URL: https://issues.jboss.org/browse/CDI-288
>             Project: CDI Specification Issues
>          Issue Type: Bug
>          Components: Portable Extensions
>    Affects Versions: 1.1.PRD
>            Reporter: Jozef Hartinger
>            Assignee: Pete Muir
>            Priority: Trivial
>             Fix For: 1.1.PFD
> *getID() vs getId()*
> There is not really a convention we could follow (http://stackoverflow.com/questions/2236807/java-naming-convention-with-acronyms).
> However, there are certain example where the latter option is prefered http://docs.oracle.com/javase/7/docs/api/java/lang/Thread.html#getId()

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

More information about the cdi-dev mailing list