[cdi-dev] [JBoss JIRA] (CDI-280) clarify usage of 'bean' term usage in the spec

Martin Andersson (JIRA) issues at jboss.org
Mon Jun 1 16:47:02 EDT 2015

    [ https://issues.jboss.org/browse/CDI-280?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13072885#comment-13072885 ] 

Martin Andersson commented on CDI-280:

What is a "tenant proxy"? You mean a proxy written by the application developer himself? If so, then I'd not worry about it at all.

Half of the rest is related to EJB and JPA.

If CDI enforce different proxy types, then it should be clarified (but it doesn't right?). "CDI proxy" would be a valid term that encapsulate all types (but again, there are no different CDI proxy types?), or just "proxy" for short. The bottom line is that if we deal with a proxy, why not just call it that? Everything in the spec is "contextual" already. The word feels a bit bloated.

Actually, I think that the word "proxy" is one of those things that is quite clear without semantic noise. Now you want to replace all references made to a proxy with "contextual reference"? I just don't get it why.

> clarify usage of 'bean' term usage in the spec
> ----------------------------------------------
>                 Key: CDI-280
>                 URL: https://issues.jboss.org/browse/CDI-280
>             Project: CDI Specification Issues
>          Issue Type: Clarification
>            Reporter: Mark Struberg
>            Assignee: Antoine Sabot-Durand
>              Labels: CDI_api_chge, CDI_spec_chge
>             Fix For: 2.0 (discussion)
> We should go to the spec and look up all 'bean' words as they are 5 different meaning the word 'bean' is used for
> * The Bean<T> extends Contextual<T>. Should be referred as 'Bean' or 'CDI Bean'
> * The class which gets scanned. Should be referred as 'Bean Class' to
> * The instance stored in the context. Should be referred to as 'Contextual Instance'
> * The proxy for a Contextual Instance should be referred to as 'Contextual Reference'
> * The type of an injection point should be referred to as 'InjectionPoint Type'

This message was sent by Atlassian JIRA

More information about the cdi-dev mailing list