[forge-dev] [JBoss JIRA] Commented: (SEAMFORGE-32) ClassNotFound when running from the IDE

Paul Bakker (JIRA) jira-events at lists.jboss.org
Thu Feb 3 10:46:39 EST 2011


    [ https://issues.jboss.org/browse/SEAMFORGE-32?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12579908#comment-12579908 ] 

Paul Bakker commented on SEAMFORGE-32:
--------------------------------------

Yes that works :-) 
I had to manually add the dist project to Intellij because it's not a module of the parent pom though, but I guess that's ok if we provide some getting started documentation later on.

> ClassNotFound when running from the IDE
> ---------------------------------------
>
>                 Key: SEAMFORGE-32
>                 URL: https://issues.jboss.org/browse/SEAMFORGE-32
>             Project: Seam Forge
>          Issue Type: Enhancement
>            Reporter: Paul Bakker
>            Priority: Minor
>
> I'm trying to get Forge working from an IDE (Intellij) by importing the pom.xml. That works but running results in a ClassNotFound for: 
> -ch.qos.cal10n and
> -javax.el
> It works after I changed the scope from test to compile. No problems when building/running with Maven though. Not sure if this is incorrect behavior but fixing it would make it easier to get started on changing code.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the forge-dev mailing list