[forge-dev] New shell feedback

Ivan St. Ivanov ivan.st.ivanov at gmail.com
Wed Jan 8 08:10:25 EST 2014

Hi folks,

As I promised, here is a [intended-to-be] short feedback about the new
Forge 2 shell. As some of you know, I use Windows (Really? OK...). So I
will be very happy to help you solve the issues besides merely reporting

* The history doesn't work. That is, when you press up and down arrows
instead of the previous commands, you get this: αH

* Backspace doesn't work. When I press it, the cursor just comes back to
the previous position without deleting the character there. If I just write
something there, the old symbol is overwritten by the new one, but at the
end after pressing enter it looks like you never entered anything after
pressing backspace. For example:
  1) I write *new-project --namek*
  2) I notice the typo and press backspace
  3) k doesn't get deleted, but I overwrite it with d
  4) Then I complete my command to look like this: *new-project --named
  5) Forge's output is: *Project name must be specified.*

* As you know on windows the full path to a file or directory is
  1) If I try to do *cd c:\temp\forge*, Forge blows with exception:
org.jboss.forge.addon.resource.ResourceException: [FileResourceImpl] can
have no
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.lang.reflect.Method.invoke(Method.java:606)
  2) Somehow I noticed that I may use the paths without the drive letter,
e.g. just \<dir1>\<dir2>. It is legal to do it in Windows, but thus you
can't change to a directory located on a different drive. For example cd
\temp\forge will change to c:\temp\forge if you are currently in c:. So I
tried *cd \temp\forge*, but the result was the same [exception].
  3) If I am in the root directory (c:\) and I run *cd temp\forge*, I don't
get exception, but ****ERROR*** tempforge\: No such file or directory*. The
interesting thing is that I ran that command by pressing tab, i.e. counting
on the command completion of the shell, which obviously works fine.

  I made the cd command work by just running *cd /temp/forge* (notice the
forward slashes)

If you wish, I may add these observations as JIRA items, probably as
children to this one: https://issues.jboss.org/browse/FORGE-1387. Bear in
mind that all the reported features work in Forge 1 even on Windows ;)

We can discuss these in today's meeting.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/forge-dev/attachments/20140108/874b181e/attachment.html 

More information about the forge-dev mailing list