[forge-dev] New shell feedback

George Gastaldi ggastald at redhat.com
Sat Jan 11 12:40:07 EST 2014


Could you open a JIRA with these issues and mark it as Blocker? We can't release 2.0.0.Final unless this is fixed.

> Em 08/01/2014, às 11:18, "Ivan St. Ivanov" <ivan.st.ivanov at gmail.com> escreveu:
> Sorry, forgot to mention that this is with snapshot from December, 29th. The situation was the same with all the previous betas and alphas.
>> On Wed, Jan 8, 2014 at 3:13 PM, George Gastaldi <ggastald at redhat.com> wrote:
>> Thanks for the feedback ivan. 
>> Are you testing against the latest snapshot? 
>> Best Regards,
>> George
>>> Em 08/01/2014, às 11:10, "Ivan St. Ivanov" <ivan.st.ivanov at gmail.com> escreveu:
>>> Hi folks,
>>> As I promised, here is a [intended-to-be] short feedback about the new Forge 2 shell. As some of you know, I use Windows (Really? OK...). So I will be very happy to help you solve the issues besides merely reporting them:
>>> * The history doesn't work. That is, when you press up and down arrows instead of the previous commands, you get this: αH
>>> * Backspace doesn't work. When I press it, the cursor just comes back to the previous position without deleting the character there. If I just write something there, the old symbol is overwritten by the new one, but at the end after pressing enter it looks like you never entered anything after pressing backspace. For example:
>>>   1) I write new-project --namek
>>>   2) I notice the typo and press backspace
>>>   3) k doesn't get deleted, but I overwrite it with d
>>>   4) Then I complete my command to look like this: new-project --named test
>>>   5) Forge's output is: Project name must be specified.
>>> * As you know on windows the full path to a file or directory is <drive-letter>:\<dir1>\<dir2>
>>>   1) If I try to do cd c:\temp\forge, Forge blows with exception:
>>> org.jboss.forge.addon.resource.ResourceException: [FileResourceImpl] can have no
>>>  children
>>>         at org.jboss.forge.addon.resource.AbstractFileResource.getChild(Abstract
>>> FileResource.java:78)
>>>         at org.jboss.forge.addon.shell.util.PathspecParser.resolve(PathspecParse
>>> r.java:232)
>>>         at org.jboss.forge.addon.shell.commands.CdCommand.execute(CdCommand.java
>>> :71)
>>>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
>>> java:57)
>>>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
>>> sorImpl.java:43)
>>>         at java.lang.reflect.Method.invoke(Method.java:606)
>>>   2) Somehow I noticed that I may use the paths without the drive letter, e.g. just \<dir1>\<dir2>. It is legal to do it in Windows, but thus you can't change to a directory located on a different drive. For example cd \temp\forge will change to c:\temp\forge if you are currently in c:. So I tried cd \temp\forge, but the result was the same [exception].
>>>   3) If I am in the root directory (c:\) and I run cd temp\forge, I don't get exception, but ***ERROR*** tempforge\: No such file or directory. The interesting thing is that I ran that command by pressing tab, i.e. counting on the command completion of the shell, which obviously works fine.
>>>   I made the cd command work by just running cd /temp/forge (notice the forward slashes)
>>> If you wish, I may add these observations as JIRA items, probably as children to this one: https://issues.jboss.org/browse/FORGE-1387. Bear in mind that all the reported features work in Forge 1 even on Windows ;)
>>> We can discuss these in today's meeting.
>>> Cheers,
>>> Ivan
>>> _______________________________________________
>>> forge-dev mailing list
>>> forge-dev at lists.jboss.org
>>> https://lists.jboss.org/mailman/listinfo/forge-dev
>> _______________________________________________
>> forge-dev mailing list
>> forge-dev at lists.jboss.org
>> https://lists.jboss.org/mailman/listinfo/forge-dev
> _______________________________________________
> forge-dev mailing list
> forge-dev at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/forge-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/forge-dev/attachments/20140111/0732824d/attachment.html 

More information about the forge-dev mailing list