[forge-issues] [JBoss JIRA] (FORGE-2484) java-new-enum-const should follow the naming convention

Antonio Goncalves (JIRA) issues at jboss.org
Sun Sep 20 01:11:00 EDT 2015


     [ https://issues.jboss.org/browse/FORGE-2484?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Antonio Goncalves updated FORGE-2484:
-------------------------------------
    Description: 
At the moment to add a new constant to an enum we type : 

{code}
java-new-enum-const VISA ;
{code}

To follow the other commands, it should have a {{named}} parameter

{code}
java-new-enum-const --named VISA ;
java-new-enum-const --named MASTER_CARD ;
java-new-enum-const --named AMERICAN_EXPRESS ;
{code}

Changing {{new}} to {{add}} we could end up with : 

{code}
java-add-enum-const --named VISA ;
java-add-enum-const --named MASTER_CARD ;
java-add-enum-const --named AMERICAN_EXPRESS ;
{code}

  was:
At the moment to add a new constant to an enum we type : 

{code}
java-new-enum-const VISA ;
{code}

To follow the other commands, it should have a {{named}} parameter

{code}
java-new-enum-const --name VISA ;
java-new-enum-const --name MASTER_CARD ;
java-new-enum-const --name AMERICAN_EXPRESS ;
{code}

Changing {{new}} to {{add}} we could end up with : 

{code}
java-add-enum-const --name VISA ;
java-add-enum-const --name MASTER_CARD ;
java-add-enum-const --name AMERICAN_EXPRESS ;
{code}



> java-new-enum-const should follow the naming convention
> -------------------------------------------------------
>
>                 Key: FORGE-2484
>                 URL: https://issues.jboss.org/browse/FORGE-2484
>             Project: Forge
>          Issue Type: Sub-task
>          Components: Java EE
>    Affects Versions: 2.19.1.Final
>            Reporter: Antonio Goncalves
>             Fix For: 2.x Future
>
>
> At the moment to add a new constant to an enum we type : 
> {code}
> java-new-enum-const VISA ;
> {code}
> To follow the other commands, it should have a {{named}} parameter
> {code}
> java-new-enum-const --named VISA ;
> java-new-enum-const --named MASTER_CARD ;
> java-new-enum-const --named AMERICAN_EXPRESS ;
> {code}
> Changing {{new}} to {{add}} we could end up with : 
> {code}
> java-add-enum-const --named VISA ;
> java-add-enum-const --named MASTER_CARD ;
> java-add-enum-const --named AMERICAN_EXPRESS ;
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.11#64026)



More information about the forge-issues mailing list