[forge-issues] [JBoss JIRA] (FORGE-2484) java-new-enum-const should follow the naming convention

George Gastaldi (JIRA) issues at jboss.org
Mon Sep 21 10:48:00 EDT 2015


    [ https://issues.jboss.org/browse/FORGE-2484?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13110888#comment-13110888 ] 

George Gastaldi commented on FORGE-2484:
----------------------------------------

The current {{java-new-enum-const}} command accepts multiple enum constants, so it's possible to do {{java-new-enum-const VISA MASTERCARD AMEX}} and generate those constants in a single execution.

Having a {{java-add-enum-const}} although interesting wouldn't add much to this command besides the nomenclature, which is a good thing.  

> java-new-enum-const should follow the naming convention
> -------------------------------------------------------
>
>                 Key: FORGE-2484
>                 URL: https://issues.jboss.org/browse/FORGE-2484
>             Project: Forge
>          Issue Type: Sub-task
>          Components: Java EE
>    Affects Versions: 2.19.1.Final
>            Reporter: Antonio Goncalves
>            Priority: Minor
>             Fix For: 2.x Future
>
>
> At the moment to add a new constant to an enum we type : 
> {code}
> java-new-enum-const VISA ;
> {code}
> To follow the other commands, it should have a {{named}} parameter
> {code}
> java-new-enum-const --named VISA ;
> java-new-enum-const --named MASTER_CARD ;
> java-new-enum-const --named AMERICAN_EXPRESS ;
> {code}
> Changing {{new}} to {{add}} we could end up with : 
> {code}
> java-add-enum-const --named VISA ;
> java-add-enum-const --named MASTER_CARD ;
> java-add-enum-const --named AMERICAN_EXPRESS ;
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.11#64026)



More information about the forge-issues mailing list