<html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Good<div>In DP it's stop() as the opposite of start() (initialize() has a different semantic for DPs)</div><div>And in RP it's destroy() as the opposite of initialize() like the Hibernate EventListeners</div><div><br></div><div>There is consistency :)</div><div><br><div> <span class="Apple-style-span" style="border-collapse: separate; color: rgb(0, 0, 0); font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: 2; text-align: auto; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-border-horizontal-spacing: 0px; -webkit-border-vertical-spacing: 0px; -webkit-text-decorations-in-effect: none; -webkit-text-size-adjust: auto; -webkit-text-stroke-width: 0; "><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><span class="Apple-style-span" style="border-collapse: separate; color: rgb(0, 0, 0); font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-border-horizontal-spacing: 0px; -webkit-border-vertical-spacing: 0px; -webkit-text-decorations-in-effect: none; -webkit-text-size-adjust: auto; -webkit-text-stroke-width: 0px; "><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><span class="Apple-style-span" style="border-collapse: separate; color: rgb(0, 0, 0); font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-border-horizontal-spacing: 0px; -webkit-border-vertical-spacing: 0px; -webkit-text-decorations-in-effect: none; -webkit-text-size-adjust: auto; -webkit-text-stroke-width: 0px; "><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div>--</div><div><div>Emmanuel Bernard</div><div><a href="http://in.relation.to/Bloggers/Emmanuel">http://in.relation.to/Bloggers/Emmanuel</a> | <a href="http://blog.emmanuelbernard.com/">http://blog.emmanuelbernard.com</a> | <a href="http://twitter.com/emmanuelbernard">http://twitter.com/emmanuelbernard</a></div><div>Hibernate Search in Action (<a href="http://is.gd/Dl1">http://is.gd/Dl1</a>)</div></div></div></span></div></span></div></span> </div><br><div><div>On Jul 19, 2008, at 03:21, Sanne Grinovero wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div dir="ltr">Yes I agree, good catch.<br>Additionally I could add some minor performance improvement<br>using a background thread in SharingBufferReaderProvider,<br>(to have the file-closing operations of unneeded segments run async)<br> but didn't implement that as I was lacking a shutdown hook.<br><br>But DirectoryProvider(s) are doing the same stuff using a "stop()" method,<br>however I like the "destroy()" name more.<br>I think for consistency they should be named the same.<br> <br>As the "stop" feature for DirectoryProviders is new in Search 3.1,<br>maybe it's still ok to change it's name?<br><br>Sanne<br><br><div class="gmail_quote">2008/7/19 Emmanuel Bernard <<a href="mailto:emmanuel@hibernate.org">emmanuel@hibernate.org</a>>:<br> <blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div style="">Should we need a readerProvider.destroy()?<div><br></div><div>ReaderProvider typically keep IndexReaders open till they are in use or if the index has been updated. But it has no hook to close the "current" IndexReaders when Hibernate Search goes down.</div> <div><br></div><div>I imagine the current code can become problematic on some VMs if we do lots of hot redeployments.</div><div><br><font color="#888888"><div> <span style="border-collapse: separate; color: rgb(0, 0, 0); font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><div style=""> <span style="border-collapse: separate; color: rgb(0, 0, 0); font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><div style=""> <span style="border-collapse: separate; color: rgb(0, 0, 0); font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><div style=""> <div>--</div><div><div>Emmanuel Bernard</div><div><a href="http://in.relation.to/Bloggers/Emmanuel" target="_blank">http://in.relation.to/Bloggers/Emmanuel</a> | <a href="http://blog.emmanuelbernard.com/" target="_blank">http://blog.emmanuelbernard.com</a> | <a href="http://twitter.com/emmanuelbernard" target="_blank">http://twitter.com/emmanuelbernard</a></div> <div>Hibernate Search in Action (<a href="http://is.gd/Dl1" target="_blank">http://is.gd/Dl1</a>)</div></div></div></span></div></span></div></span> </div><br></font></div></div><br>_______________________________________________<br> hibernate-dev mailing list<br> <a href="mailto:hibernate-dev@lists.jboss.org">hibernate-dev@lists.jboss.org</a><br> <a href="https://lists.jboss.org/mailman/listinfo/hibernate-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/hibernate-dev</a><br> <br></blockquote></div><br></div></blockquote></div><br></div></body></html>