<div dir="ltr"><div><br></div><div class="gmail_extra"><br><div class="gmail_quote">On Wed, Oct 8, 2014 at 5:42 PM, William Burns <span dir="ltr">&lt;<a href="mailto:mudokonman@gmail.com" target="_blank">mudokonman@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">So it seems we would want to change this for 7.0 if possible since it<br>
would be a bigger change for something like 7.1 and 8.0 would be even<br>
further out.  I should be able to put this together for CR2.<br></blockquote><div><br></div><div>I&#39;m not 100% convinced that we need it for 7.x. For 8.0 I would recommend removing the size() method altogether, and providing some looser &quot;statistics&quot; instead.</div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">
<br>
It seems that we want to implement keySet, values and entrySet methods<br>
using the entry iterator approach.<br>
<br>
It is however unclear for the size method if we want to use MR entry<br>
counting and not worry about the rehash and passivation issues since<br>
it is just an estimation anyways.  Or if we want to also use the entry<br>
iterator which should be closer approximation but will require more<br>
network overhead and memory usage.<br></blockquote><div><br></div><div>+1 to use the entry iterator from me, ignoring state transfer we can get some pretty wild fluctuations in the size of the cache.</div><div>We could use a distributed task for Cache.isEmpty() instead of size() == 0, though.</div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">
<br>
Also we didn&#39;t really talk about the fact that these methods would<br>
ignore ongoing transactions and if that is a concern or not.<br>
<br></blockquote><div><br></div><div>It might be a concern for the Hibernate 2LC impl, it was their TCK that prompted the last round of discussions about clear(). </div><div><br></div><div>We haven&#39;t talked about what size(), keySet() and values() should return for an invalidation cache either... I forget, does the distributed entry iterator work with invalidation caches?<br></div><div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">
 - Will<br>
<div class=""><div class="h5"><br>
On Wed, Oct 8, 2014 at 10:13 AM, Mircea Markus &lt;<a href="mailto:mmarkus@redhat.com">mmarkus@redhat.com</a>&gt; wrote:<br>
&gt;<br>
&gt; On Oct 8, 2014, at 15:11, Dan Berindei &lt;<a href="mailto:dan.berindei@gmail.com">dan.berindei@gmail.com</a>&gt; wrote:<br>
&gt;<br>
&gt;&gt;<br>
&gt;&gt; On Wed, Oct 8, 2014 at 5:03 PM, Mircea Markus &lt;<a href="mailto:mmarkus@redhat.com">mmarkus@redhat.com</a>&gt; wrote:<br>
&gt;&gt; On Oct 3, 2014, at 9:30, Radim Vansa &lt;<a href="mailto:rvansa@redhat.com">rvansa@redhat.com</a>&gt; wrote:<br>
&gt;&gt;<br>
&gt;&gt; &gt; Hi,<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; recently we had a discussion about what size() returns, but I&#39;ve<br>
&gt;&gt; &gt; realized there are more things that users would like to know. My<br>
&gt;&gt; &gt; question is whether you think that they would really appreciate it, or<br>
&gt;&gt; &gt; whether it&#39;s just my QA point of view where I sometimes compute the<br>
&gt;&gt; &gt; &#39;checksums&#39; of cache to see if I didn&#39;t lost anything.<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; There are those sizes:<br>
&gt;&gt; &gt; A) number of owned entries<br>
&gt;&gt; &gt; B) number of entries stored locally in memory<br>
&gt;&gt; &gt; C) number of entries stored in each local cache store<br>
&gt;&gt; &gt; D) number of entries stored in each shared cache store<br>
&gt;&gt; &gt; E) total number of entries in cache<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; So far, we can get<br>
&gt;&gt; &gt; B via withFlags(SKIP_CACHE_LOAD).size()<br>
&gt;&gt; &gt; (passivation ? B : 0) + firstNonZero(C, D) via size()<br>
&gt;&gt; &gt; E via distributed iterators / MR<br>
&gt;&gt; &gt; A via data container iteration + distribution manager query, but only<br>
&gt;&gt; &gt; without cache store<br>
&gt;&gt; &gt; C or D through<br>
&gt;&gt; &gt; getComponentRegistry().getLocalComponent(PersistenceManager.class).getStores()<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; I think that it would go along with users&#39; expectations if size()<br>
&gt;&gt; &gt; returned E and for the rest we should have special methods on<br>
&gt;&gt; &gt; AdvancedCache. That would of course change the meaning of size(), but<br>
&gt;&gt; &gt; I&#39;d say that finally to something that has firm meaning.<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; WDYT?<br>
&gt;&gt;<br>
&gt;&gt; There was a lot of arguments in past whether size() and other methods that operate over all the elements (keySet, values) are useful because:<br>
&gt;&gt; - they are approximate (data changes during iteration)<br>
&gt;&gt; - they are very resource consuming and might be miss-used (this is the reason we chosen to use size() with its current local semantic)<br>
&gt;&gt;<br>
&gt;&gt; These methods (size, keys, values) are useful for people and I think we were not wise to implement them only on top of the local data: this is like preferring efficiency over correctness. This also created a lot of confusion with our users, question like size() doesn&#39;t return the correct value being asked regularly. I totally agree that size() returns E (i.e. everything that is stored within the grid, including persistence) and it&#39;s performance implications to be documented accordingly. For keySet and values - we should stop implementing them (throw exception) and point users to Will&#39;s distributed iterator which is a nicer way to achieve the desired behavior.<br>
&gt;&gt;<br>
&gt;&gt; We can also implement keySet() and values() on top of the distributed entry iterator and document that using the iterator directly is better.<br>
&gt;<br>
&gt; Yes, that&#39;s what I meant as well.<br>
&gt;<br>
&gt; Cheers,<br>
&gt; --<br>
&gt; Mircea Markus<br>
&gt; Infinispan lead (<a href="http://www.infinispan.org" target="_blank">www.infinispan.org</a>)<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; _______________________________________________<br>
&gt; infinispan-dev mailing list<br>
&gt; <a href="mailto:infinispan-dev@lists.jboss.org">infinispan-dev@lists.jboss.org</a><br>
&gt; <a href="https://lists.jboss.org/mailman/listinfo/infinispan-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/infinispan-dev</a><br>
<br>
_______________________________________________<br>
infinispan-dev mailing list<br>
<a href="mailto:infinispan-dev@lists.jboss.org">infinispan-dev@lists.jboss.org</a><br>
<a href="https://lists.jboss.org/mailman/listinfo/infinispan-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/infinispan-dev</a><br>
</div></div></blockquote></div><br></div></div>