[jboss-user] [JBoss/Spring Integration] - Re: Jboss 5 Beta 2 and Spring Deployer

alesj do-not-reply at jboss.com
Thu Jan 3 07:47:19 EST 2008


I've just added (commited in the trunk) a legacy default name support to SpringParserDeployer.

The current default is still from meta file: -spring.xml.
But if you set this flag to true, the name from jar containing -spring.xml file will be used.

>From SpringParserDeployer:

  |    /**
  |     * Should we use deployment unit's name as default.
  |     * e.g. using string before .jar|spring|... as the name
  |     *
  |     * Previous versions used string before .spring as the name,
  |     * setting this to true results in this legacy behaviour.
  |     *
  |     * Current default is string before -spring.xml.
  |     *
  |     * @param useLegacyDefaultName the flag
  |     */
  |    public void setUseLegacyDefaultName(boolean useLegacyDefaultName)
  |    {
  |       this.useLegacyDefaultName = useLegacyDefaultName;
  |    }
  | 

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4116706#4116706

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4116706



More information about the jboss-user mailing list