[jbossts-issues] [JBoss JIRA] Updated: (JBTM-882) org.jboss.jbossts:jbossjts:jar have to use PROVIDED scope dependency on org.jboss.logging:jboss-logging-generator:jar

Richard Opalka (JIRA) jira-events at lists.jboss.org
Tue Sep 13 09:47:26 EDT 2011


     [ https://issues.jboss.org/browse/JBTM-882?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Richard Opalka updated JBTM-882:
--------------------------------

    Description: 
The org.jboss.jbossts:jbossjts:jar
in AS7 trunk brings in the compile dependency on 
org.jboss.logging:jboss-logging-generator

The identified dependency tree is:
{code}
[INFO] | | | +- org.jboss.jbossts:jbossjts:jar:4.15.3.Final:compile
[INFO] | | | | +- commons-httpclient:commons-httpclient:jar:3.1-jbossorg-1:compile
[INFO] | | | | +- emma:emma:jar:2.0.5312:compile
[INFO] | | | | +- emma:emma_ant:jar:2.0.5312:compile
[INFO] | | | | | \- ant:ant:jar:1.6.3:compile
[INFO] | | | | +- org.hornetq:hornetq-core:jar:2.2.6.Final:compile
[INFO] | | | | +- tanukisoft:wrapper:jar:3.2.3:compile
[INFO] | | | | +- jacorb:jacorb:jar:2.3.1jboss.patch01-brew:compile
[INFO] | | | | +- jacorb:idl:jar:2.3.1jboss.patch01-brew:compile
[INFO] | | | | +- org.jboss.integration:jboss-corba-ots-spi:jar:6.0.0.CR1:compile
[INFO] | | | | | \- org.jboss.javaee:jboss-transaction-api:jar:1.0.1.GA:compile
[INFO] | | | | +- org.jboss.jbossas:jboss-server-manager:jar:1.0.4.Final:compile
[INFO] | | | | | \- org.picketbox:jboss-security-spi:jar:3.0.0.CR2:runtime
[INFO] | | | | +- org.jboss.remoting:jboss-remoting:jar:2.5.3:compile
[INFO] | | | | +- dom4j:dom4j:jar:1.6.1:compile
[INFO] | | | | +- org.jboss.logging:jboss-logging-generator:jar:1.0.0.Beta6:compile                  <<<< wrong dependency scope here
[INFO] | | | | \- org.hibernate.javax.persistence:hibernate-jpa-2.0-api:jar:1.0.1.Final:compile
[INFO] | | | +- org.jboss.jbossts:jbossjts-integration:jar:4.15.3.Final:compile
{code}

  was:
The org.jboss.jbossts:jbossjts:jar
in AS7 trunk brings in the compile dependency on 
org.jboss.logging:jboss-logging-generator

The identified dependency tree is:
[INFO] | | | +- org.jboss.jbossts:jbossjts:jar:4.15.3.Final:compile
[INFO] | | | | +- commons-httpclient:commons-httpclient:jar:3.1-jbossorg-1:compile
[INFO] | | | | +- emma:emma:jar:2.0.5312:compile
[INFO] | | | | +- emma:emma_ant:jar:2.0.5312:compile
[INFO] | | | | | \- ant:ant:jar:1.6.3:compile
[INFO] | | | | +- org.hornetq:hornetq-core:jar:2.2.6.Final:compile
[INFO] | | | | +- tanukisoft:wrapper:jar:3.2.3:compile
[INFO] | | | | +- jacorb:jacorb:jar:2.3.1jboss.patch01-brew:compile
[INFO] | | | | +- jacorb:idl:jar:2.3.1jboss.patch01-brew:compile
[INFO] | | | | +- org.jboss.integration:jboss-corba-ots-spi:jar:6.0.0.CR1:compile
[INFO] | | | | | \- org.jboss.javaee:jboss-transaction-api:jar:1.0.1.GA:compile
[INFO] | | | | +- org.jboss.jbossas:jboss-server-manager:jar:1.0.4.Final:compile
[INFO] | | | | | \- org.picketbox:jboss-security-spi:jar:3.0.0.CR2:runtime
[INFO] | | | | +- org.jboss.remoting:jboss-remoting:jar:2.5.3:compile
[INFO] | | | | +- dom4j:dom4j:jar:1.6.1:compile
[INFO] | | | | +- org.jboss.logging:jboss-logging-generator:jar:1.0.0.Beta6:compile                  <<<< wrong dependency scope here
[INFO] | | | | \- org.hibernate.javax.persistence:hibernate-jpa-2.0-api:jar:1.0.1.Final:compile
[INFO] | | | +- org.jboss.jbossts:jbossjts-integration:jar:4.15.3.Final:compile



> org.jboss.jbossts:jbossjts:jar have to use PROVIDED scope dependency on org.jboss.logging:jboss-logging-generator:jar
> ---------------------------------------------------------------------------------------------------------------------
>
>                 Key: JBTM-882
>                 URL: https://issues.jboss.org/browse/JBTM-882
>             Project: JBoss Transaction Manager
>          Issue Type: Bug
>      Security Level: Public(Everyone can see) 
>    Affects Versions: 4.15.3
>            Reporter: Richard Opalka
>             Fix For: 4.15.x
>
>
> The org.jboss.jbossts:jbossjts:jar
> in AS7 trunk brings in the compile dependency on 
> org.jboss.logging:jboss-logging-generator
> The identified dependency tree is:
> {code}
> [INFO] | | | +- org.jboss.jbossts:jbossjts:jar:4.15.3.Final:compile
> [INFO] | | | | +- commons-httpclient:commons-httpclient:jar:3.1-jbossorg-1:compile
> [INFO] | | | | +- emma:emma:jar:2.0.5312:compile
> [INFO] | | | | +- emma:emma_ant:jar:2.0.5312:compile
> [INFO] | | | | | \- ant:ant:jar:1.6.3:compile
> [INFO] | | | | +- org.hornetq:hornetq-core:jar:2.2.6.Final:compile
> [INFO] | | | | +- tanukisoft:wrapper:jar:3.2.3:compile
> [INFO] | | | | +- jacorb:jacorb:jar:2.3.1jboss.patch01-brew:compile
> [INFO] | | | | +- jacorb:idl:jar:2.3.1jboss.patch01-brew:compile
> [INFO] | | | | +- org.jboss.integration:jboss-corba-ots-spi:jar:6.0.0.CR1:compile
> [INFO] | | | | | \- org.jboss.javaee:jboss-transaction-api:jar:1.0.1.GA:compile
> [INFO] | | | | +- org.jboss.jbossas:jboss-server-manager:jar:1.0.4.Final:compile
> [INFO] | | | | | \- org.picketbox:jboss-security-spi:jar:3.0.0.CR2:runtime
> [INFO] | | | | +- org.jboss.remoting:jboss-remoting:jar:2.5.3:compile
> [INFO] | | | | +- dom4j:dom4j:jar:1.6.1:compile
> [INFO] | | | | +- org.jboss.logging:jboss-logging-generator:jar:1.0.0.Beta6:compile                  <<<< wrong dependency scope here
> [INFO] | | | | \- org.hibernate.javax.persistence:hibernate-jpa-2.0-api:jar:1.0.1.Final:compile
> [INFO] | | | +- org.jboss.jbossts:jbossjts-integration:jar:4.15.3.Final:compile
> {code}

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the jbossts-issues mailing list