[jsr-314-open] #{compositeComponent.attrs....}

Martin Marinschek mmarinschek at APACHE.ORG
Mon Apr 13 01:09:08 EDT 2009


> <h:graphicImage style="border: none" value="#{faceletsContext.image}"/>
>
> This satisfies Ken's best practice in this use case.

this also seems reasonable to me, however, Andy's approach would make
it possible to be even more concise in the naming. Also, I would
expect the scope should rather be named something like:

#{compositeScope.image}

actually, that looks pretty likable, too.

In the end, I wouldn't worry too much about having a few (not too many
of course - the current syntax is probably hard to remember)
boilerplate characters - I would only worry about these chars if we
have to transfer all attributes of a component in the main view
definition to the composite component, and for this, I think we should
really add an <f:insertAttributes except="..."/> element at some
(later) point of time.

regards,

Martin




More information about the jsr-314-open-mirror mailing list