[keycloak-dev] Keycloak M1 distribution

Bill Burke bburke at redhat.com
Wed Oct 30 16:08:35 EDT 2013

I wanted the distro to be AS7 or Wildfly distro, not just a war.  All 
preconfigured with SSL, DB, etc.  An appliance.  Would be cool to 
auto-gen a new key-pair for SSL on initial startup, but not sure how 
feasible that is.

If I had to pick one or the other, distro should take priority over 
Openshift, but we should be able to do both.

Also, not sure how much it makes sense to ship a Wildfly distro without 
a Wildfly application adapter.  I only partially implemented it a few 
months ago.  It on the short list for my todo list.

I kind of want picketlink gone so we don't have to deal with the 
bullshit you're dealing with.  We'll hook it back in for LDAP, et. al. 
That would require building a backend for it though so probalby can't 
get rid of it for M1.

We still have like 30+ other open issues, btw... We're still missing a 
few admin things too.

On 10/30/2013 3:27 PM, Stian Thorgersen wrote:
> What will the distribution of Keycloak be for M1? Just keycloak-server.war? Should this be deployable to AS 7.1.1.Final and WildFly?
> OpenShift QuickStart
> --------------------
> For OpenShift I thought a QuickStart using the AS 7.1.1.Final cartridge would be the simplest option. The QuickStart basically is a github repo that contains a starting point to get Keycloak installed. It would update the Resteasy version + install keycloak-server.war. To start a Keycloak instance using rhc you'd use:
> # rhc app-create keycloak jbossas-7 --from-code https://github.com/keycloak/keycloak-openshift-quickstart.git
> We could also make the QuickStart automatically configure Keycloak to use PostgreSQL if available. For example if creating a Keycloak instance with the following it would use PostgreSQL instead of H2:
> # rhc app-create keycloak jbossas-7 postgresql-9.2 --from-code https://github.com/keycloak/keycloak-openshift-quickstart.git
> WildFly
> -------
> I've tried to run Keycloak on WildFly and ran into a PicketLink/Hibernate issue (see https://issues.jboss.org/browse/KEYCLOAK-135 for details). PicketLink guys have merged fix, but that would require upgrading to 2.5.3.Final when it's released.
> I've also tried to upgrade to PicketLink 2.5.2.Final, but am having some issues with the ApplicationData/Entity. When loading the Application from the database, PicketLink tries to set a RealmData on ApplicationData.resourceUser which you may imagine throws an exception. I've added it to https://github.com/stianst/keycloak/tree/pl-2.5. It's either a bug in PicketLink, or a mistake in ApplicationData/Entity, I'm not sure which though.
> _______________________________________________
> keycloak-dev mailing list
> keycloak-dev at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/keycloak-dev

Bill Burke
JBoss, a division of Red Hat

More information about the keycloak-dev mailing list