[keycloak-dev] Keycloak distribution changes

Bill Burke bburke at redhat.com
Tue Apr 21 13:07:47 EDT 2015


For the server too.  we have a number of people deploying server on EAP 
6.  IMO, we should probably keep this until EAP 7 is available in beta.

On 4/21/2015 11:36 AM, Marko Strukelj wrote:
>
>> * Installer has to work on EAP 6.x too.
>
> I suppose you only mean it for adapter, not for the server?
>
> Currently auth-server support is only part of wildfly-subsystem, which ATM also contains EAP 6.x support which makes it use deprecated subsystem APIs. Keeping things that way is not a good foundation for the future on top of WildFly 10.
>
> The server / adapter subsystem split will result in wildfly-subsystem become wildfly-server-subsystem, and wildfly-adapter-subsystem. In order to keep things clean we would have to extract EAP 6.x support out into another module.
>
> There is wildfly-as7-subsystem which currently only contains adapter support. Since EAP 6.x is API compatible with AS7 it seems a better place for EAP 6.x parts.
>

-- 
Bill Burke
JBoss, a division of Red Hat
http://bill.burkecentral.com


More information about the keycloak-dev mailing list