[keycloak-dev] Keycloak 3.2 & Clustering

John D. Ament john.d.ament at gmail.com
Thu Jun 1 08:15:26 EDT 2017


I haven't tried all permutations.  I'm in general having issues getting
clustering to work 100% in 11, similar to testing I did on 10 to see how to
make KC clustering work in my environment.

The option I'm using is the registration of a datasource to do the
JDBC_PING instead of duplicating the JDBC configuration.  My hunch is that
jgroups is being initialized before the datasource is, and as a result it
can't find the data source.  This implies though that the module itself
isn't available either.

I haven't gotten any TCP based configurations to work, including OOTB.  UDP
at least boots but I haven't tried a two node cluster yet to confirm


On Thu, Jun 1, 2017 at 3:59 AM Stian Thorgersen <sthorger at redhat.com> wrote:

> Is JDBC_PING not working at all? Or is it something specific with your
> config? Seems like something that would important to get fixed before WF 11
> FInal is released.
> On 1 June 2017 at 05:15, John D. Ament <john.d.ament at gmail.com> wrote:
>> All,
>> I'm not sure what the current release state looks like, but wanted to
>> bring
>> your attention to an issue in WF11 I had raised.  It actually impacts the
>> clustering pieces, which is pretty important to keycloak.
>> https://issues.jboss.org/browse/WFLY-8488
>> Basically, a number of jgroups configs no longer work in WF11.  I'm not
>> sure if you have a way to escalate this, since it has pretty important
>> impact to Keycloak.
>> John
> _______________________________________________
>> keycloak-dev mailing list
>> keycloak-dev at lists.jboss.org
>> https://lists.jboss.org/mailman/listinfo/keycloak-dev

More information about the keycloak-dev mailing list