[keycloak-dev] Change the binding name in ScriptBasedAuthenticator?
mposolda at redhat.com
Thu May 25 12:24:43 EDT 2017
Hi Thomas and all,
In 3.2 we did some refactoring and authenticators are now using
authenticationSession instead of ClientSession. I see if we should do
something for the ScriptBasedAuthenticator as it;s still using
"clientSession" as binding where it puts authentication session. I can
see the possibilities:
1) Keep the binding name "clientSession" for backwards compatibility
2) Change the binding name. Probably to "authenticationSession" ? It
would need to be documented in the migration guide.
My vote is to rather go with 2 as people will likely need to refactor
their scripts anyway. Some method signatures are same for authentication
session like was for client session, but not all. WDYT? Other idea?
More information about the keycloak-dev