[keycloak-user] Error on application log in

Marek Posolda mposolda at redhat.com
Fri Nov 14 03:27:29 EST 2014


it failed on the adapter (application) side and error 404 means "Not 
found". So adapter can't find the keycloak server to turn code into 
token. Make sure to configure "auth-server-url" in keycloak.json for 
your application properly. If relative uri doesn't work for some reason, 
you can rather try to use absolute uri for auth-server-url like 
"https://localhost:8443/auth" .


On 14.11.2014 01:31, Fabián Silva wrote:
> I have a keycloak installed on wildfly standalone. I'm trying to 
> deploy an application, that use this keycloak, on a separate server 
> with wilflly running on domain mode. I tried first to deploy on a 
> domain out of the box on my local machine, setting the 
> keycloak-wildfly-adapter-dist-1.0.4.Final. It deploys fine and does 
> the authentication without any issues. When I try to migrate it to the 
> server running my wilfly (also in domain mode and the keycloak adapter 
> set), it deploys fine and shows the keycloak login once you enter the 
> application. But the problem is that when you login it displays a "403 
> - Forbidden" and on the log I'm seeing
> ERROR [org.keycloak.adapters.OAuthRequestAuthenticator] (default 
> task-6) failed to turn code into token
> ERROR [org.keycloak.adapters.OAuthRequestAuthenticator] (default 
> task-6) status from server: 404
> The only difference between those two wildfly domain mode is that in 
> the local I don't have the the SSL/HTTPS enabled.
> Have anyone seen this error? or have an idea of what this could be?
> Regards
> _______________________________________________
> keycloak-user mailing list
> keycloak-user at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/keycloak-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/keycloak-user/attachments/20141114/c6a35218/attachment.html 

More information about the keycloak-user mailing list