[rhmessaging-commits] rhmessaging commits: r4317 - store/trunk/cpp/lib.

rhmessaging-commits at lists.jboss.org rhmessaging-commits at lists.jboss.org
Tue Sep 21 11:51:59 EDT 2010


Author: kpvdr
Date: 2010-09-21 11:51:59 -0400 (Tue, 21 Sep 2010)
New Revision: 4317

Modified:
   store/trunk/cpp/lib/MessageStoreImpl.cpp
   store/trunk/cpp/lib/MessageStoreImpl.h
Log:
Renamed the MessageStore interface truncateInit parameter to a more generic name. Matches qpid checkin r.999473. This is a tidy-up only, there should be no code implications.

Modified: store/trunk/cpp/lib/MessageStoreImpl.cpp
===================================================================
--- store/trunk/cpp/lib/MessageStoreImpl.cpp	2010-09-21 15:11:36 UTC (rev 4316)
+++ store/trunk/cpp/lib/MessageStoreImpl.cpp	2010-09-21 15:51:59 UTC (rev 4317)
@@ -396,7 +396,7 @@
     }
 }
 
-void MessageStoreImpl::truncateInit(const bool pushDownStoreFiles)
+void MessageStoreImpl::truncateInit(const bool saveStoreContent)
 {
     if (isInit) {
         {
@@ -415,8 +415,8 @@
     }
     std::ostringstream oss;
     oss << storeDir << "/" << storeTopLevelDir;
-    if (pushDownStoreFiles) {
-        QPID_LOG(notice, "Store directory " << oss.str() << " was pushed down into directory " << mrg::journal::jdir::push_down(storeDir, storeTopLevelDir, "cluster") << ".");
+    if (saveStoreContent) {
+        QPID_LOG(notice, "Store directory " << oss.str() << " was pushed down (saved) into directory " << mrg::journal::jdir::push_down(storeDir, storeTopLevelDir, "cluster") << ".");
     } else {
         mrg::journal::jdir::delete_dir(oss.str().c_str());
         QPID_LOG(notice, "Store directory " << oss.str() << " was truncated.");

Modified: store/trunk/cpp/lib/MessageStoreImpl.h
===================================================================
--- store/trunk/cpp/lib/MessageStoreImpl.h	2010-09-21 15:11:36 UTC (rev 4316)
+++ store/trunk/cpp/lib/MessageStoreImpl.h	2010-09-21 15:51:59 UTC (rev 4317)
@@ -289,7 +289,7 @@
               bool      autoJExpand = defAutoJrnlExpand,
               u_int16_t autoJExpandMaxFiles = defAutoJrnlExpandMaxFiles);
 
-    void truncateInit(const bool pushDownStoreFiles = false);
+    void truncateInit(const bool saveStoreContent = false);
 
     void initManagement (qpid::broker::Broker* broker);
 



More information about the rhmessaging-commits mailing list