that would be a major breakage though - as a lot of people don&#39;t use that. Would want to take some time enforcing it. <div><br></div><div>It looks ugly to me, but I can understand why people like it, even if I don&#39;t. <br>
<br><div class="gmail_quote">On Fri, Sep 24, 2010 at 9:50 AM, Mauricio Salatino <span dir="ltr">&lt;<a href="mailto:salaboy@gmail.com">salaboy@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
cool.. I think that it&#39;s a great idea to enforce it.. <div>giving people to much choices to do the same always complicates things.<div><div></div><div class="h5"><br><br><div class="gmail_quote">On Thu, Sep 23, 2010 at 8:46 PM, Mark Proctor <span dir="ltr">&lt;<a href="mailto:mproctor@codehaus.org" target="_blank">mproctor@codehaus.org</a>&gt;</span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

  
    
  
  <div bgcolor="#ffffff" text="#000000">
    yes, ? wasn&#39;t easy due to java and data munging would get messy as
    we map between things.<br>
    <br>
    So we just left it as any valid java identifier, but using the $
    prefix as a coding convention make it easier to differentiate
    fieldnames and bindings<br>
    Person( age : age )<br>
    Person( age == age )<br>
     <br>
    The above looks a little confusing compared to:<br>
    Person( $age : age )<br>
    Person( age == $age )<br>
    <br>
    Davide wants to enforce the $ prefix so that parsing can be easier.<br><font color="#888888">
    <br>
    Mark</font><div><div></div><div><br>
    On 24/09/2010 00:31, Michael Neale wrote:
    <blockquote type="cite">The $name: Pattern thing I am convinced is to do with
      Mark&#39;s prior history of being abused by perl ;)
      <div><br>
      </div>
      <div>But the real reason is we wanted to use ?name: Pattern() -
        using &quot;?&quot; like the clips lineage of languages - but IIRC even
        ilog allows that. We wanted our labels to be compatible with
        java source code - where $variable is a valid name (although no
        one actually uses it) and ?name is not. </div>
      <div><br>
        So here we are ;)</div>
      <div><br>
        <br>
        <div class="gmail_quote">On Fri, Sep 24, 2010 at 12:29 AM, Greg
          Barton <span dir="ltr">&lt;<a href="mailto:greg_barton@yahoo.com" target="_blank">greg_barton@yahoo.com</a>&gt;</span>
          wrote:<br>
          <blockquote class="gmail_quote" style="margin:0pt 0pt 0pt 0.8ex;border-left:1px solid rgb(204, 204, 204);padding-left:1ex">
            <div bgcolor="#FFFFFF">
              <div>Yes, and I don&#39;t think we want to take readability
                cues from Perl. :)<br>
                <font color="#888888"><br>
                  GreG</font></div>
              <div>
                <div>
                  <div><br>
                    On Sep 23, 2010, at 3:03, Wolfgang Laun &lt;<a href="mailto:wolfgang.laun@gmail.com" target="_blank">wolfgang.laun@gmail.com</a>&gt;
                    wrote:<br>
                    <br>
                  </div>
                  <blockquote type="cite">
                    <div>On 23 September 2010 09:31, Bruno Unna <span dir="ltr">&lt;<a href="mailto:bruno.unna@gmail.com" target="_blank">bruno.unna@gmail.com</a>&gt;</span>
                      wrote:<br>
                      <div class="gmail_quote">
                        <blockquote class="gmail_quote" style="border-left:1px solid rgb(204, 204, 204);margin:0pt 0pt 0pt 0.8ex;padding-left:1ex">
                          <div>FWIW: in Perl, there are both operators
                            as well (|| and &#39;or&#39;). However, they are
                            *not* exactly the same. Although they can be
                            used in any context to render a boolean
                            expression, their priority makes the
                            difference. Taken from official
                            documentation (<a href="http://bit.ly/dgw4GT" target="_blank">http://bit.ly/dgw4GT</a>):
                            <div>
                              <br>
                            </div>
                          </div>
                        </blockquote>
                        <div><br>
                          Low precedence &quot;and&quot;, &quot;or&quot;, &quot;xor&quot; were
                          introduced to permit &quot;Perl poetry&quot;, or, more
                          seriously, to<br>
                          permit control flow using a logical
                          expression, especially after function calls
                          without parentheses. <br>
                             see Naples or die;  # same as: see(Napes)
                          || die(); but not: see(Naples || die() );<br>
                          <br>
                          No way this makes any sense in Drools.<br>
                          <br>
                          -W<br>
                          <br>
                        </div>
                        <blockquote class="gmail_quote" style="border-left:1px solid rgb(204, 204, 204);margin:0pt 0pt 0pt 0.8ex;padding-left:1ex">
                          <div>
                            <div>
                              <blockquote type="cite">Binary &quot;or&quot;
                                returns the logical disjunction of the
                                two surrounding
                                expressions. It&#39;s equivalent to ||
                                except for the very low precedence.
                                This makes it useful for control flow.</blockquote>
                            </div>
                            <div><br>
                            </div>
                            <div>Nonetheless, it must be taken into
                              account that the distinction makes sense
                              for a Perl programmer. For a rules-writing
                              guy (or girl) perhaps the distinction is
                              extremely obscure.</div>
                            <div><br>
                            </div>
                            <div>Regards.<br>
                              <div><br>
                              </div>
                              <br>
                            </div>
                          </div>
                        </blockquote>
                      </div>
                      <br>
                    </div>
                  </blockquote>
                </div>
              </div>
              <div>
                <blockquote type="cite">
                  <div><span>_______________________________________________</span><br>
                    <span>rules-dev mailing list</span><br>
                    <span><a href="mailto:rules-dev@lists.jboss.org" target="_blank">rules-dev@lists.jboss.org</a></span><br>
                    <span><a href="https://lists.jboss.org/mailman/listinfo/rules-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/rules-dev</a></span><br>
                  </div>
                </blockquote>
                <br>
              </div>
            </div>
            <br>
            _______________________________________________<br>
            rules-dev mailing list<br>
            <a href="mailto:rules-dev@lists.jboss.org" target="_blank">rules-dev@lists.jboss.org</a><br>
            <a href="https://lists.jboss.org/mailman/listinfo/rules-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/rules-dev</a><br>
            <br>
          </blockquote>
        </div>
        <br>
        <br clear="all">
        <br>
        -- <br>
        Michael D Neale<br>
        home: <a href="http://www.michaelneale.net" target="_blank">www.michaelneale.net</a><br>
        blog: <a href="http://michaelneale.blogspot.com" target="_blank">michaelneale.blogspot.com</a><br>
      </div>
      <pre><fieldset></fieldset>
_______________________________________________
rules-dev mailing list
<a href="mailto:rules-dev@lists.jboss.org" target="_blank">rules-dev@lists.jboss.org</a>
<a href="https://lists.jboss.org/mailman/listinfo/rules-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/rules-dev</a>
</pre>
    </blockquote>
    <br>
  </div></div></div>

<br>_______________________________________________<br>
rules-dev mailing list<br>
<a href="mailto:rules-dev@lists.jboss.org" target="_blank">rules-dev@lists.jboss.org</a><br>
<a href="https://lists.jboss.org/mailman/listinfo/rules-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/rules-dev</a><br>
<br></blockquote></div><br><br clear="all"><br></div></div>-- <br> - CTO @ <a href="http://www.plugtree.com" target="_blank">http://www.plugtree.com</a>  <br> - MyJourney @ <a href="http://salaboy.wordpress.com" target="_blank">http://salaboy.wordpress.com</a><br>

 - Co-Founder @ <a href="http://www.jbug.com.ar" target="_blank">http://www.jbug.com.ar</a><br> <br> - Salatino &quot;Salaboy&quot; Mauricio -<br>
</div>
<br>_______________________________________________<br>
rules-dev mailing list<br>
<a href="mailto:rules-dev@lists.jboss.org">rules-dev@lists.jboss.org</a><br>
<a href="https://lists.jboss.org/mailman/listinfo/rules-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/rules-dev</a><br>
<br></blockquote></div><br><br clear="all"><br>-- <br>Michael D Neale<br>home: <a href="http://www.michaelneale.net">www.michaelneale.net</a><br>blog: <a href="http://michaelneale.blogspot.com">michaelneale.blogspot.com</a><br>

</div>