<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#ffffff">
    Look at your responses i would say ignore the content of the
    examples, they are there just to illustrate the syntax not to show a
    valid use case or scenario. What I'm doing is looking to other
    languages to see what works there and try to bring them across, the
    CEP type uses cases rely a lot more on functional programming
    capabilities.<br>
    <br>
    On 31/10/2010 13:01, Wolfgang Laun wrote:
    <blockquote
      cite="mid:AANLkTinBh8Dq55Jrr7fBW+_tK78MFmzSFxDdAnjV+-y2@mail.gmail.com"
      type="cite">Hello Mark,<br>
      <br>
      I've been thinking about this, on and off, for 5 days now, and I
      still<br>
      fail to see the benefits. Perhaps there are more convincing use
      cases<br>
      than those in your original mail?<br>
      <br>
      Notice that the "for" scope now contains two kinds of bindings:
      one that<br>
      is strictly local to for(...) (bi below) and another one that must
      be exported<br>
      such as the binding $s in<br>
      <br>
      &nbsp; for( bi : BasketItem( customer == $c ); $s = sum( $bi.price); )<br>
    </blockquote>
    We can certainly make it:<br>
    $s : sum(....)<br>
    <br>
    My thinking is we still need to create a sytnax to assign the
    results of the expression when it returns a collection, instead of
    iterating it. For this I was thinking of introducting:<br>
    $var = someexpr;<br>
    <br>
    We can't do the following as there isn't enough of a differentiator
    in the syntax between normal patterns.<br>
    $var : someexpr;<br>
    <br>
    But we can do = for assignment of expr, but keep : for bindings of a
    functional result. Just seeing how different things look.<br>
    <blockquote
      cite="mid:AANLkTinBh8Dq55Jrr7fBW+_tK78MFmzSFxDdAnjV+-y2@mail.gmail.com"
      type="cite"><br>
      This will be confusing.<br>
      <br>
      <br>
      I fail to see the usefulness of filter() in<br>
      <br>
      &nbsp;&nbsp; for( $b2 : BasketItem( customer == $c ); filter( $b2, $b2.price
      &gt; 100) )<br>
    </blockquote>
    filter is just a function, like min, max and average, it's not
    special. Functional programming has a number of higher order
    functions, filter, map and fold. There is nothing extra to support
    that, so it's just added for completeness to show we could/can do
    it.<br>
    <blockquote
      cite="mid:AANLkTinBh8Dq55Jrr7fBW+_tK78MFmzSFxDdAnjV+-y2@mail.gmail.com"
      type="cite"><br>
      where one can better (and perhaps even more efficiently) write<br>
      <br>
      &nbsp;&nbsp; for( $b2 : BasketItem( customer == $c, price &gt; 100) )<br>
    </blockquote>
    The filter function was just an example for completeness, it could
    have been any function name.<br>
    <blockquote
      cite="mid:AANLkTinBh8Dq55Jrr7fBW+_tK78MFmzSFxDdAnjV+-y2@mail.gmail.com"
      type="cite"> <br>
      I don't understand what this construct should achieve:<br>
      <br>
      &nbsp;&nbsp;&nbsp; $r = $bi | map( $, $.price * 2) | filter( $, $.price &lt;
      100);<br>
    </blockquote>
    I wouldn't take the example as "best practice"or actually meaningful
    I was just trying to illustrate the syntax. <br>
    <blockquote
      cite="mid:AANLkTinBh8Dq55Jrr7fBW+_tK78MFmzSFxDdAnjV+-y2@mail.gmail.com"
      type="cite"><br>
      Given that $bi iterates over BasketItem objects, the first map
      would create<br>
      a numeric value by doubling $bi.price, so I suppose the next
      pipeline transmits<br>
      numbers so that filtering applies to - what? java.lang.Number?
      Then it can't be<br>
      $.price; </blockquote>
    The contents is automatically passed into the function. The first
    argument is what the higher order "map" function would store, the
    second one is the modifier. Typically "map" is single argument map(
    * 2 ), but I can't see how that would work for our syntax,
    especially when passing objects instead of values.<br>
    <br>
    <blockquote
      cite="mid:AANLkTinBh8Dq55Jrr7fBW+_tK78MFmzSFxDdAnjV+-y2@mail.gmail.com"
      type="cite">it could be $.floatValue or similar. But again: the
      entire selection<br>
      could be written as a constraint of the BaskerItem pattern.
      Creating a<br>
      collection just for determining a count isn't straightforward.<br>
      <br>
      The idea of accumulate is to produce a scalar result from
      processing a<br>
      collection of facts.</blockquote>
    <blockquote
      cite="mid:AANLkTinBh8Dq55Jrr7fBW+_tK78MFmzSFxDdAnjV+-y2@mail.gmail.com"
      type="cite"> It would indeed be useful to extend this so that a
      result<br>
      tuple can be constructed. But this could be achieved by a complex<br>
      accumulate function that returns an object with multiple fields;<br>
      in fact, min/max/count/avg/sum can be wrapped into a single
      function<br>
      "stats" returning an object of class "Statistics" with appropriate
      fields.<br>
      Any filtering on the result can be written as a constraint on that<br>
      temporary fact pattern of type Statistics, e.g.:<br>
      <br>
      Statistics( $min: min, $max: max )<br>
      &nbsp; from accumulate( $bi: BasketItem( $p: price ) stats( $p ) )<br>
    </blockquote>
    that's something that can be achieved now, but requires plumbing
    from the end user. Multiple functions support would avoid that and
    is what people from other products would expect. The last part of
    the acc provides the propagation constraint, it's sugar to avoid
    verbosity.<br>
    <blockquote
      cite="mid:AANLkTinBh8Dq55Jrr7fBW+_tK78MFmzSFxDdAnjV+-y2@mail.gmail.com"
      type="cite"> <br>
      All that remains is the syntactic sugar that's provided by <br>
      &nbsp;&nbsp; x in [0..4]<br>
      &nbsp;&nbsp; y in [0..4]<br>
      &nbsp;&nbsp; $c : Cell( row == y, col == x );<br>
      as a on-the-fly pattern for selecting other patterns. Again, this
      could be<br>
      written more concisely as<br>
    </blockquote>
    Don't take the example as "best practice". It's showing that 'in',
    which is the same as 'from', can look more compact and is what
    people from a more functional world would expect.<br>
    <br>
    i'm thinking of allowing 'from' and 'in' to be used interchangable.
    Where 'from' would be used with "from entry-point" where as 'in' for
    iterationg the results of an expression.<br>
    <br>
    &nbsp;CEP cases can also need specific ordering, the example below could
    find the cells in any order.<br>
    <blockquote
      cite="mid:AANLkTinBh8Dq55Jrr7fBW+_tK78MFmzSFxDdAnjV+-y2@mail.gmail.com"
      type="cite"> &nbsp; $c : Cell( row &gt;= 0 &amp;&amp; &lt;= 4, col
      &gt;= 0 &amp;&amp; &lt;= 4 )<br>
      and a (minor) extension such as a set expression might simplify
      this:<br>
      &nbsp; $c : Cell( row in [0..4], col in [0,1,2,3,4] )<br>
      <br>
      Regards<br>
      Wolfgang<br>
      <br>
      <div class="gmail_quote">On 26 October 2010 01:36, Mark Proctor <span
          dir="ltr">&lt;<a moz-do-not-send="true"
            href="mailto:mproctor@codehaus.org" target="_blank">mproctor@codehaus.org</a>&gt;</span>
        wrote:<br>
        <blockquote class="gmail_quote" style="border-left: 1px solid
          rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left:
          1ex;">We are thinking of moving "accumulate" to a simple "for"
          keyword. We<br>
          might allow 'in' and 'from' to be used interchangably and
          allow ';' semi<br>
          colons to separate the sections. I'm also wondering ho we
          could allow<br>
          function pipelines for the function part of the element. We
          also need<br>
          type inference and "default" return values.<br>
          <br>
          So here are some code snippets to show what I'm thinking, as<br>
          improvements over what we do with accumulate now.<br>
          <br>
          // Simple 'or' very simlar to accumulate before. ; for section<br>
          separating. With a new boolean section at the end to decide
          whether to<br>
          propagate or not. Will probably use '=' for function
          assignments.<br>
          $c : Customer()<br>
          for( $bi : BasketItem( customer == $c );<br>
          &nbsp; &nbsp; &nbsp; &nbsp; $s = sum( $bi.price);<br>
          &nbsp; &nbsp; &nbsp; &nbsp; $s &gt; 100 )<br>
          <br>
          // Multiple functions are ofcourse allowed<br>
          $c : Customer()<br>
          for( $bi : BasketItem( customer == $c );<br>
          &nbsp; &nbsp; &nbsp; &nbsp; $mn =min( $bi.price),<br>
          &nbsp; &nbsp; &nbsp; &nbsp; $mx = max( $bi.price); )<br>
          <br>
          // As are multiple patterns, and as before patterns can come
          'from' an<br>
          expression and with type inference we can get some nice
          compact text:<br>
          for ( x in [0..4]<br>
          &nbsp; &nbsp; &nbsp; y in [0..4]<br>
          &nbsp; &nbsp; &nbsp; $c : Cell( row == y, col == x );<br>
          &nbsp; &nbsp; &nbsp; $avg = avg( $cell.value );<br>
          &nbsp; &nbsp; &nbsp; $avg &gt; 100 )<br>
          <br>
          The above is possible now with the following:<br>
          Integer( this &gt; 100) from<br>
          &nbsp; &nbsp; accumulate( x : Integer() from [0, 1, 2, 3, 4]<br>
          &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; y : Integer() from [0, 1, 2, 3, 4],<br>
          &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; $c : Cell( row == y, col == x ),<br>
          &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; avg( $c.value) )<br>
          <br>
          I think the proposed additions reall help with declarative
          readability.<br>
          <br>
          The normal chaining of elements is supported:<br>
          $c : Customer()<br>
          for( $b1 : BasketItem() in<br>
          &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; for( $b2 : BasketItem( customer == $c );<br>
          &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;filter( $b2, $b2.price &gt; 100); );<br>
          &nbsp; &nbsp; &nbsp; &nbsp; $a = avg( $b1.price ); )<br>
          <br>
          'for' will have a default return type for each bound function.
          In this<br>
          case it returns a single value $a, if there are multiple bound
          results<br>
          an array/map must be used for access.<br>
          <br>
          I also think we should allow pipelineing of functions, much as
          you would<br>
          do in a normal functional programming, possibly using haskell
          like<br>
          "stream fusion" capable functions.<br>
          <br>
          // '$' refers to the magic contents of the function which is
          "piped" in.<br>
          So $bi is piped to map, $ refers to each value evaluated in
          the<br>
          function, with type inference. 'map' results are piped to
          'filter'. The<br>
          final results are assigned to $r.<br>
          $c : Customer()<br>
          for( $bi : BasketItem( customer == $c );<br>
          &nbsp; &nbsp; &nbsp; &nbsp; $r = $bi | map( $, $.price * 2) |<br>
          &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;filter( $, $.price &lt; 100);<br>
          &nbsp; &nbsp; &nbsp; &nbsp; $r.size &gt; 100 )<br>
          <br>
          More ideas welcome :) But I think this opens up some very
          interesting<br>
          areas for DRL, with something that will hopefully feel more
          natural for<br>
          developers.<br>
          <br>
          Mark<br>
          <br>
          _______________________________________________<br>
          rules-dev mailing list<br>
          <a moz-do-not-send="true"
            href="mailto:rules-dev@lists.jboss.org" target="_blank">rules-dev@lists.jboss.org</a><br>
          <a moz-do-not-send="true"
            href="https://lists.jboss.org/mailman/listinfo/rules-dev"
            target="_blank">https://lists.jboss.org/mailman/listinfo/rules-dev</a><br>
        </blockquote>
      </div>
      <br>
      <pre wrap=""><fieldset class="mimeAttachmentHeader"></fieldset>
_______________________________________________
rules-dev mailing list
<a class="moz-txt-link-abbreviated" href="mailto:rules-dev@lists.jboss.org">rules-dev@lists.jboss.org</a>
<a class="moz-txt-link-freetext" href="https://lists.jboss.org/mailman/listinfo/rules-dev">https://lists.jboss.org/mailman/listinfo/rules-dev</a>
</pre>
    </blockquote>
    <br>
  </body>
</html>