Ugh, though using this package convention means that hiding classes via package-private is less appealing.<br><br><div class="gmail_quote">On Fri, Apr 16, 2010 at 3:17 PM, Lincoln Baxter, III <span dir="ltr"><<a href="mailto:lincolnbaxter@gmail.com">lincolnbaxter@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">I should add that I'm fine with using whatever packaging schema the Interceptor would reside in without such a convention, but this protects us from refactoring, so I think it's a good idea.<br>
<font color="#888888"><br>--Lincoln</font><div><div></div><div class="h5"><br><br>
<div class="gmail_quote">On Fri, Apr 16, 2010 at 3:16 PM, Lincoln Baxter, III <span dir="ltr"><<a href="mailto:lincolnbaxter@gmail.com" target="_blank">lincolnbaxter@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Ok - so this means we are back to square one. Can we discuss and agree on the following guidelines?<br><br>All @Interceptor classes must:<br><ol><div><li>Adhere to the following package and naming scheme: org.jboss.seam.intercept.*Interceptor<br>
</li></div><li>Warn users (or Error out when appropriate) if they are using
interceptable @Annotations when the @Inteceptor itself is not
registered, and provide instructions to correct the configuration:<div><br>(@Interceptor registration can be checked in the Extension class AfterBeanDiscovery via BeanManager.resolveInterceptors(type, interceptorBindings)</div>
</li>
</ol>All @Decorator classes must:<br>
<ol><li>Adhere to the following package and naming scheme: org.jboss.seam.decorate.*Decorator</li></ol>
Let's discuss and resolve, since we're starting to release, and this is important. (Affects Faces directly.)<br><br>Thanks,<br><font color="#888888">Lincoln</font><div><div></div><div><br><br><div class="gmail_quote">
On Mon, Apr 12, 2010 at 7:26 AM, Pete Muir <span dir="ltr"><<a href="mailto:pmuir@redhat.com" target="_blank">pmuir@redhat.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div><br>
On 11 Apr 2010, at 05:11, Gavin King wrote:<br>
<br>
> On Wed, Apr 7, 2010 at 7:23 AM, Pete Muir <<a href="mailto:pmuir@redhat.com" target="_blank">pmuir@redhat.com</a>> wrote:<br>
><br>
>> BTW A slightly better approach (which avoids at least the nastiness of this approach, but<br>
>> doesn't avoid the issue of ordering - which IMO is insurmountable) is to write a<br>
>> SeamInterceptor which can cope with using relative ordering semantics and require users<br>
>> to just enable that.<br>
><br>
> Sure, but the problem is that then you can't interleave other<br>
> interceptors with the Seam interceptors.<br>
<br>
</div>Perhaps I should have prefaced it "a slightly better-than-terrible way" ;-)<br>
<div><div></div><div>_______________________________________________<br>
seam-dev mailing list<br>
<a href="mailto:seam-dev@lists.jboss.org" target="_blank">seam-dev@lists.jboss.org</a><br>
<a href="https://lists.jboss.org/mailman/listinfo/seam-dev" target="_blank">https://lists.jboss.org/mailman/listinfo/seam-dev</a><br>
</div></div></blockquote></div><br><br clear="all"><br></div></div><div><div></div><div>-- <br>Lincoln Baxter, III<br><a href="http://ocpsoft.com" target="_blank">http://ocpsoft.com</a><br><a href="http://scrumshark.com" target="_blank">http://scrumshark.com</a><br>
"Keep it Simple"<br>
</div></div></blockquote></div><br><br clear="all"><br>-- <br>Lincoln Baxter, III<br><a href="http://ocpsoft.com" target="_blank">http://ocpsoft.com</a><br><a href="http://scrumshark.com" target="_blank">http://scrumshark.com</a><br>
"Keep it Simple"<br>
</div></div></blockquote></div><br><br clear="all"><br>-- <br>Lincoln Baxter, III<br><a href="http://ocpsoft.com">http://ocpsoft.com</a><br><a href="http://scrumshark.com">http://scrumshark.com</a><br>"Keep it Simple"<br>