Referring to protection from refactoring:<br><ul><li>We have a class in: org.jboss.seam.faces.context.conversation.ConversationBoundaryInterceptor</li></ul>Three months later, we do some refactoring, and that interceptor moves (because it doesn't really matter where it lives, as long as it is enabled -- again, this problem would be solved by some sort of automatic enabling and ordering.)<br>
<ul><li>The class is now in: org.jboss.seam.faces.conversation.ConversationBoundaryInterceptor</li></ul>We just broke all of our existing users -- now, this is of course easy to prevent: don't move the class, but it is a concern that could lead to code fragility and brittleness.<br>
<br>--Lincoln<br><br><div class="gmail_quote">On Mon, Apr 19, 2010 at 11:22 AM, Dan Allen <span dir="ltr"><<a href="mailto:dan.j.allen@gmail.com">dan.j.allen@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="gmail_quote"><div class="im">On Mon, Apr 19, 2010 at 5:48 AM, Pete Muir <span dir="ltr"><<a href="mailto:pmuir@redhat.com" target="_blank">pmuir@redhat.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div>> All @Interceptor classes must:</div><div>
> • Adhere to the following package and naming scheme: org.jboss.seam.intercept.*Interceptor<br>
<br>
</div>No, why would we want to do this? Classes defined in a module should reside in a package owned by that package. It prevents any risk of namespace clashes<br><br></blockquote></div><div>Referring back to Lincoln's suggestion, I though we were using org.jboss.seam.{module}.intercept.*Interceptor? That would make them easier to locate in the API docs yet still reside in a package owned by the module. I just worry that if we scatter interceptors (and decorators) further down in the packaging of a module, it will be harder to enforce consistency from one module to the next. Is that a reasonable convention?</div>
<div><br></div><font color="#888888"><div>-Dan</div><div> </div></font></div><div><div></div><div class="h5">-- <br>Dan Allen<br>Senior Software Engineer, Red Hat | Author of Seam in Action<br>Registered Linux User #231597<br>
<br><a href="http://mojavelinux.com" target="_blank">http://mojavelinux.com</a><br>
<a href="http://mojavelinux.com/seaminaction" target="_blank">http://mojavelinux.com/seaminaction</a><br><a href="http://www.google.com/profiles/dan.j.allen" target="_blank">http://www.google.com/profiles/dan.j.allen</a><br>
</div></div></blockquote></div><br><br clear="all"><br>-- <br>Lincoln Baxter, III<br><a href="http://ocpsoft.com">http://ocpsoft.com</a><br><a href="http://scrumshark.com">http://scrumshark.com</a><br>"Keep it Simple"<br>