[jbossseam-issues] [JBoss JIRA] Commented: (JBSEAM-1099) s:button does not show both image and text

Alex Narinsky (JIRA) jira-events at lists.jboss.org
Mon Mar 26 18:53:03 EDT 2007

    [ http://jira.jboss.com/jira/browse/JBSEAM-1099?page=comments#action_12357389 ] 
Alex Narinsky commented on JBSEAM-1099:

Thank you for checking.  I tested this again - still the same result.  If we specify both value and image for s:button only image is shown if it is found.

For Firefox if the image is not found then "value"  is displayed, for IE6 an empty image is displayed in this case.

The HTML difference is that "input" with type="image" contains a "value" attribute additionally.  This does not make a difference for display

> s:button does not show both image and text
> ------------------------------------------
>                 Key: JBSEAM-1099
>                 URL: http://jira.jboss.com/jira/browse/JBSEAM-1099
>             Project: JBoss Seam
>          Issue Type: Bug
>          Components: JSF
>    Affects Versions: 1.2.0.GA
>            Reporter: Alex Narinsky
> I need to create a button that shows both text and image.  I found that if I use s:button then after image specification the text does not show up.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: http://jira.jboss.com/jira/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the seam-issues mailing list