[switchyard-issues] [JBoss JIRA] Created: (SWITCHYARD-234) InOutOperation: make the constructors consistent and use 'operationName' instead of 'operationType'

Daniel Bevenius (JIRA) jira-events at lists.jboss.org
Mon May 23 10:29:00 EDT 2011


InOutOperation: make the constructors consistent and use 'operationName' instead of 'operationType' 
----------------------------------------------------------------------------------------------------

                 Key: SWITCHYARD-234
                 URL: https://issues.jboss.org/browse/SWITCHYARD-234
             Project: SwitchYard
          Issue Type: Task
          Components: core
            Reporter: Daniel Bevenius
            Priority: Minor


The following constructors can be found in InOutOperation:
{code:title=Bar.java|borderStyle=solid}
public InOutOperation(String operationName) {
   this(operationName, null, null, null);
}
public InOutOperation(String operationType, QName inputType, QName outputType) {
    super(inputType, outputType, null);
    _operationName = operationType;
}
public InOutOperation(String operationType, QName inputType, QName outputType, QName faultType) {
    super(inputType, outputType, faultType);
    _operationName = operationType;
}
{code}


--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the switchyard-issues mailing list