On Nov 28, 2012, at 9:37 AM, Sebastien Blanc <scm.blanc@gmail.com> wrote:

Hi all,
Related to Jira 574 [1] and the as-quickstarts repo [2], I would like to ask your opinion about the folders name. Currently we have :

- helloword-html5
- kitchensink-cordova
- kitchensink-html5-mobile 

Now, we will add quickstarts using the aerogear libraries, so we will have : 

- helloword-html5
- helloword-aerogear
- kitchensink-cordova
- kitchensink-html5-mobile 
- kitchensink-aerogear

But the suffix "aerogear" is maybe a bit too generic as we are talking here about "web" quickstarts, so what for suffix should add ? js ? web ? html5
for instance with js : 
- helloword-html5
- helloword-aerogear-js
- kitchensink-cordova
- kitchensink-html5-mobile 
- kitchensink-aerogear-js

So in the future we could have kitchensink-aerogear-ios , etc ...

i like this approach

kitchensink-cordova has a shared "www" folder, so I'm not sure how to split this in a smart way but that can maybe wait a bit.


[1] https://issues.jboss.org/browse/AEROGEAR-574
[2] https://github.com/aerogear/as-quickstarts
aerogear-dev mailing list