On Mon, Oct 21, 2013 at 1:57 PM, Sebastien Blanc <scm.blanc@gmail.com> wrote:



On Mon, Oct 21, 2013 at 1:12 PM, Matthias Wessendorf <matzew@apache.org> wrote:

Hello,

for [1] I'd like to propose a slight change to the message format spec ([2]):

The introduction of a new field, called 'ttl', which contains a value (in seconds). This value will be translated (by the UnifiedPush Server) into the specific details of the supported platforms (GCM and APNs; NOTE: SimplePush standard does not this support this atm)...

An example for a message which expires in one hour:

curl -3 -u "{PushApplicationID}:{MasterSecret}"
   -v -H "Accept: application/json" -H "Content-type: application/json" 
   -X POST
   -d '{
       "alias" : ["user@account.com"],
       "ttl" : 3600, // expires in one hour
       "message": {
         "alert":"URGENT CALL!!!!",
         "sound":"default"
       }
     }'

https://SERVER:PORT/CONTEXT/rest/sender

On our fluent client APIs (NodeJS and Java), I'd propose we add a timeToLive(secondsInInt) method to the APIs;

Any thoughts ?

Sounds good ! For the client I think even the 'ttl' shortcut is acecptable (with good javadoc).   


I'd prefer a more readable signature, since chars here don't count :-)

-M 

_______________________________________________
aerogear-dev mailing list
aerogear-dev@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--
Matthias Wessendorf

blog: http://matthiaswessendorf.wordpress.com/
sessions: http://www.slideshare.net/mwessendorf
twitter: http://twitter.com/mwessendorf