[~darahayes] So the current shape of the self-defence check metric in the android impĺementation is
{code:javascript} { "clientId": "453de743207a0232a339a23e5d64b289", "timestamp": "8377194421", "data": { <name of self-defence check impl java class>: { passed: true } } } {code}
See https://github.com/aerogear/aerogear-android-sdk/blob/master/auth/src/main/java/org/aerogear/mobile/security/metrics/SecurityCheckResultMetric.java#L18. In which {{nonNull(result, "result").getName();}} is currently defaulting to the java.lang.Class.getName() method for all check implementations.
[~davidmartin] [~wtrocki] [~danielpassos] We should be able to PR against the android sdk overriding the name/identifier for the checks and perhaps document a naming scheme so these checks would match with their equivalent implementations across the other sdks. I think it would be important for checks with the same semantics to have the same metrics identifiers.
For example https://github.com/aerogear/aerogear-android-sdk/blob/master/auth/src/main/java/org/aerogear/mobile/security/checks/EmulatorCheck.java 's identifier being `IsEmulatorCheck` instead of `org.aerogear.mobile.security.EmulatorCheck` so it could match iOS's (and cordova's?) implementation. |
|