For some reason I thought it made more sense to call this message Handshake instead of Hello as it is referred to in the spec. This is just confusing and this task should change the name of the HandshakeMessage in the protocol.
The task should also verify that the hello message can contain an empty uaid.
The task should also verify that the hello message that the channelIDs field can be empty.
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira