Change By: Matthias Wessendorf (20/Dec/12 10:42 AM)
Description: Inside of the following classes we have a getter, to get an actual object by its name:
- AGPipeline
- AGDataManager
- AGAuthenticator

However, this is not best practice. Usually a method that starts with 'get' deliver values by reference 

See NSColor (https://developer.apple.com/library/mac/#documentation/Cocoa/Reference/ApplicationKit/Classes/NSColor_Class/Reference/Reference.html)
{code}
- (void)getComponents:(CGFloat *)components
{code}


Instead of, for instance:
{code}
- (id<AGAuthenticationModule>)get:(NSString *)moduleName
{code}

we can have something LIKE this:
{code}
- (id<AGAuthenticationModule>)loadModuleNamed:(NSString *)moduleName
{code}





Current 'get' methods:
* https://github.com/aerogear/aerogear-ios/blob/master/AeroGear-iOS/AeroGear-iOS/pipeline/AGPipeline.h#L88
* https://github.com/aerogear/aerogear-ios/blob/master/AeroGear-iOS/AeroGear-iOS/datamanager/AGDataManager.h#L62
* https://github.com/aerogear/aerogear-ios/blob/master/AeroGear-iOS/AeroGear-iOS/security/AGAuthenticator.h#L62
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira