Rename the Developer class and map it correctly with picketlink model
Description:
https://github.com/aerogear/aerogear-unifiedpush-server/blob/master/src/main/java/org/jboss/aerogear/unifiedpush/users/Developer.java is confusing since Developer is also a role.
I propose to rename it to UnifiedPushUser.
In the same time we should make sure this class is correctly mapped with the picketlink model in order to be able to store custom fields.
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira