Hi all,

Hardy and I were wondering whether the method name ExecutableDescriptor#areParametersConstrained() is the best choice.

The name seems a bit unintuitive, when e.g. looking via auto-completion for boolean getter methods which typically start with "is" or "has". Maybe 

* "isParameterConstrained()" (as in "is constrained on at least one parameter") or 
* "hasConstrainedParameters()" would be better alternatives?

The latter would also nicely match with BeanDescriptor#hasConstrainedExecutables().