hi gunnar,

imo that's too verbose and maybe not that clear/intuitive due to the different (implicit) constellations.

regards,
gerhard



2013/3/13 Gunnar Morling <gunnar@hibernate.org>
> but we would need then probably another object in BootstrapConfiguration wrapping the
> executable-validation config. I am not sure this is worth it.

We could also do

    <executable-validation enabled="true|false">

        <executable-type>GETTER_METHODS</executable-type>
        <executable-type>CONSTRUCTORS</executable-type>
    </executable-validation>

I'd slightly prefer an explicit list element for the executable types. I think this reads better, should we add another sub-element to <executable-validation> one day. But I could also live with the simpler form I guess.




2013/3/13 Hardy Ferentschik <hardy@hibernate.org>

On 13 Jan 2013, at 11:54 AM, Gunnar Morling <gunnar@hibernate.org> wrote:

> What I like about approach #2 is that it bundles the configuration related to executable validation in one element.
>
> Maybe an attribute could be used for the flag:
>
>     <executable-validation enabled="true|false">
>         <default-validated-executables>
>             <executable-type>NONE</executable-type>
>         </default-validated-executables>
>     </executable-validation>

the enabled flag seems need, but we would need then probably another object in BootstrapConfiguration wrapping the
executable-validation config. I am not sure this is worth it.

> Generally I like "positive" flag names better than negated ones (i.e. "enabled" instead of "disabled").

In this case I actually prefer isValidationExecutionDisabled(). That's the more relevant/interesting case.

--Hardy
_______________________________________________
beanvalidation-dev mailing list
beanvalidation-dev@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/beanvalidation-dev


_______________________________________________
beanvalidation-dev mailing list
beanvalidation-dev@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/beanvalidation-dev