Hi all,

While discussing some details around BVAL-340 (allowing constraints to be generic and cross-parameter at the same time), Emmanuel and myself were wondering whether @ParameterListConstraint might be a better name for what's currently named @CrossParameterConstraint.

I like the alternative name because it makes very clear to what the constraint applies, the list of parameters of a method or constructor.

Any thoughts?