The second possibility looks nicer. I'd choose that instead of the first one. "doSearch" isn't that intuitive IMHO.

Best Regards,
George Gastaldi

Em 09/09/2012, às 11:39, "Lincoln Baxter, III" <> escreveu:

Ooooh that's an unfortunate problem! We can certainly change this, though. I personally like the idea of "doSearch()" because it is more descriptive than "example". WDYT?


On Sun, Sep 9, 2012 at 5:39 AM, Thomas Frühbeck <> wrote:

just found a subtle problem in the generated faces application.
The backing beans carry the property "search" for form field based dynamic query and the method search() to invoke the selection.
After adding Seam3 Faces module to the project the application fails on "Search" because the ELResolver will take the method search() instead of the property "search" first:

Caused by: javax.el.PropertyNotFoundException: /searchTest/search.xhtml @34,90 value="#{}": Target Unreachable, 'search' returned null

So I see 2 possibilities for remedy:
    1. rename method "search()" to sth. like "doSearch()"
    2. rename property "search" to "example"

I personally like second poss. more, because it matches the kinda "query-by-example" mechanism and the method name "search()" is most descriptive.

Any ideas welcome!


forge-dev mailing list

Lincoln Baxter, III
"Simpler is better."
forge-dev mailing list