---------- Forwarded message ----------
From: George Gastaldi <ggastald@redhat.com>
Date: Thu, Jan 9, 2014 at 11:58 PM
Subject: Re: Forge 2 core tests
To: "Ivan St. Ivanov" <ivan.st.ivanov@gmail.com>

Hum, this may be due to file locking issues perhaps. Lincoln is pushing some changes in Furnace, so it's worth building it too before building core.

Btw forge -i core installs the latest released version (NOT the snapshot).
You must use run forge -i org.jboss.forge.addon:core,2.0.0-SNAPSHOT instead

Em 09/01/2014, ās 19:43, "Ivan St. Ivanov" <ivan.st.ivanov@gmail.com> escreveu:

Hey George,

Here is what I tried:

1) I activated the profile that points to the snapshots repository
2) I run mvn clean install -DskipTests on all the core
3) I deleted the ~/.forge/addons directory
4) I run forge --install core
5) I ran forge and executed addon-list. It worked fine
6) I ran maven clean install in core/addon-manager. The test failed again

I noticed that inside the target directory there are two furnacexxxxxxx directories. I looked inside and found that they are both lacking the addon-manager addon. So I think that this may be the reason why the addon-list command timed out?


On Thu, Jan 9, 2014 at 12:20 AM, Ivan St. Ivanov <ivan.st.ivanov@gmail.com> wrote:
Isn't it weird? In order to test the addon-manager addon, you have to first have it installed in ~\.forge\addons?

On Thu, Jan 9, 2014 at 12:14 AM, George Gastaldi <ggastald@redhat.com> wrote:
It should be inside this directory with a name like the maven coordinates

Em 08/01/2014, ās 20:11, "Ivan St. Ivanov" <ivan.st.ivanov@gmail.com> escreveu:

Ah, so it takes it from ~/forge/addons?

On Thu, Jan 9, 2014 at 12:10 AM, George Gastaldi <ggastald@redhat.com> wrote:
It belongs to the addons project afaik. 

Run a mvn clean install, go to dist/target, unzip the file and run forge -i org.jboss.forge.addon:core,2.0.0-SNAPSHOT

Em 08/01/2014, ās 20:08, "Ivan St. Ivanov" <ivan.st.ivanov@gmail.com> escreveu:

Hmm, there is no such command addon-list in my forge installation, that is why the command fails. Most probably the command was recently added, as I see it in Eclipse.

AddonListCommandTest has declared an addon dependency to org.jboss.forge.addon:addon-manager. Where does it take it from?

On Wed, Jan 8, 2014 at 11:53 PM, George Gastaldi <ggastald@redhat.com> wrote:
This looks like a bug in the shell impl or aesh itself. Try running the "addon-list" command in a running Forge 2 instance to check the output

> Em 08/01/2014, ās 19:46, "Ivan St. Ivanov" <ivan.st.ivanov@gmail.com> escreveu:
> Hi George,
> As I promised you, I ran the Forge 2 core tests. Initially the maven impl tests failed, because my settings.xml pointed to the snapshots repository, while the test was trying to access artifacts from version 2.0.0.Alpha3, which can be found in the releases repository. After changing the repo to releases, the test passed.
> Next, I got a failure in AddonListCommandTest::testAddonListCommand. The reason is timeout: 10 seconds are not enough for the test to pass. Do you know how I can look for the reason?
> Thanks,
> Ivan