Which version of Forge 2 is included in the version of JBoss Tools exhibiting the problem?


On Thu, May 30, 2013 at 6:32 PM, George Gastaldi <ggastald@redhat.com> wrote:
Max,

Probably https://issues.jboss.org/browse/MODULES-136 describes better what's going on.
We have fixed this by forking JBM. 
It should not happen in the latest available version 2.0.0.Alpha4

Best Regards,

George Gastaldi

Em 30/05/2013, ās 18:49, Max Rydahl Andersen <manderse@redhat.com> escreveu:

Heya,

We just got this posted on jbosstools-dev at https://community.jboss.org/message/820446#820446

Problem of xmldocument factory builders being messed up.

I've asked for more details but I went and looked in forge 2 code base and found this
at https://github.com/forge/core/blob/2.0/container/src/main/java/org/jboss/forge/furnace/modules/providers/AbstractModuleSpecProvider.java#L115

systemPaths.add("__redirected");

and in https://github.com/jbossas/jboss-modules/blob/master/src/main/java/__redirected/__DocumentBuilderFactory.java

Meaning my best guess is that Forge 2 is somehow leaking jboss modules isolation into eclipse osgi which just can't be allowed
since it breaks the platform.

Any idea of what we can do to get this tracked down and fixed ASAP ?

Please post on the forum post so Juergen can see it too.

Thank you,
Max
_______________________________________________
forge-dev mailing list
forge-dev@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/forge-dev

_______________________________________________
forge-dev mailing list
forge-dev@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/forge-dev



--
Lincoln Baxter, III
http://ocpsoft.org
"Simpler is better."