[JBoss JIRA] (FORGE-1299) command-list missing
by Antonio Goncalves (JIRA)
[ https://issues.jboss.org/browse/FORGE-1299?page=com.atlassian.jira.plugin... ]
Antonio Goncalves updated FORGE-1299:
-------------------------------------
Summary: command-list missing (was: list-command missing)
> command-list missing
> --------------------
>
> Key: FORGE-1299
> URL: https://issues.jboss.org/browse/FORGE-1299
> Project: Forge
> Issue Type: Sub-task
> Components: UI - Shell
> Affects Versions: 2.0.0.Alpha14
> Reporter: Antonio Goncalves
> Fix For: 2.x Future
>
>
> {{list-command}} and {{list-command --all}} are missing in the CLI. That is quite an important one to have an idea of the commands.
> But following the issue [FORGE-944] it should be {{command-list}} instead of {{list-command}} (component-verb)
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 1 month
[JBoss JIRA] (FORGE-1401) What does --primitive do ?
by Antonio Goncalves (JIRA)
Antonio Goncalves created FORGE-1401:
----------------------------------------
Summary: What does --primitive do ?
Key: FORGE-1401
URL: https://issues.jboss.org/browse/FORGE-1401
Project: Forge
Issue Type: Sub-task
Components: UI - Shell
Affects Versions: 2.0.0.Beta4
Reporter: Antonio Goncalves
The {{jpa-new-field}} has a {{--primitive}} attribute but I don't know its usage. First I thought it was the primitive datatype (int, float...) but this is the {{--typeName}}.
{code}
[PurchaseOrder.java]$ jpa-new-field
--typeName --named --lob --relationshipType --entity --length --primitive
{code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 1 month
[JBoss JIRA] (FORGE-1400) java command is missing
by Antonio Goncalves (JIRA)
Antonio Goncalves created FORGE-1400:
----------------------------------------
Summary: java command is missing
Key: FORGE-1400
URL: https://issues.jboss.org/browse/FORGE-1400
Project: Forge
Issue Type: Sub-task
Components: UI - Shell
Affects Versions: 2.0.0.Beta4
Reporter: Antonio Goncalves
I need to create an enum and the {{java}} command is missing. With the new syntax in Forge 2.x, what I need to do is :
{code}
java-new-enum --named CreditCardType --package org.agoncal.application.petstore.model ;
java-new-enum-const VISA ;
java-new-enum-const AMERICAN_EXPRESS ;
java-new-enum-const MASTER_CARD ;
{code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 1 month
[JBoss JIRA] (FORGE-1399) Cannot create a relationship between two entities
by Antonio Goncalves (JIRA)
Antonio Goncalves created FORGE-1399:
----------------------------------------
Summary: Cannot create a relationship between two entities
Key: FORGE-1399
URL: https://issues.jboss.org/browse/FORGE-1399
Project: Forge
Issue Type: Sub-task
Components: UI - Shell
Affects Versions: 2.0.0.Beta4
Reporter: Antonio Goncalves
I've created a {{Country}} entity and then a {{Customer}}. When I create a relationship between both, I have an error :
{code}
[Customer.java]$ jpa-new-field --named country --entity org.agoncal.application.petstore.model.Country --relationshipType Many-to-One
***ERROR*** No Facet of type [interface org.jboss.forge.addon.javaee.jpa.JPAFacet] is installed.
[Customer.java]$ jpa-setup
***ERROR*** No Facet of type [interface org.jboss.forge.addon.javaee.jpa.JPAFacet] is installed.
{code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 1 month
[JBoss JIRA] (FORGE-1398) Being able to create embeddables
by Antonio Goncalves (JIRA)
Antonio Goncalves created FORGE-1398:
----------------------------------------
Summary: Being able to create embeddables
Key: FORGE-1398
URL: https://issues.jboss.org/browse/FORGE-1398
Project: Forge
Issue Type: Sub-task
Components: UI - Shell
Affects Versions: 2.0.0.Beta4
Reporter: Antonio Goncalves
As per [FORGE-797] it would be good to have a new command to create an embeddable :
{code}
jpa-new-embeddable --named Address ;
jpa-new-field --named street1 --length 50 ;
jpa-new-field --named street2 ;
jpa-new-field --named city --length 50 ;
jpa-new-field --named state ;
{code}
Then, how do we embed it into a entity ? We could have a new {{--relationshipType}} :
{code}
jpa-new-entity --named Customer ;
jpa-new-field --named address --entity org.agoncal.application.petstore.model.Address --relationshipType Embedded ;
{code}
Except {{Address}} is not an entity. So having {{--entity}} pointing to an embeddable looks strange
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 1 month
[JBoss JIRA] (FORGE-1397) How to create a jpa-new-field of type Date ?
by Antonio Goncalves (JIRA)
Antonio Goncalves created FORGE-1397:
----------------------------------------
Summary: How to create a jpa-new-field of type Date ?
Key: FORGE-1397
URL: https://issues.jboss.org/browse/FORGE-1397
Project: Forge
Issue Type: Sub-task
Components: UI - Shell
Affects Versions: 2.0.0.Beta4
Reporter: Antonio Goncalves
To create a Date in Forge 1.x we would type :
{code}
field temporal --named dateOfBirth --type DATE ;
{code}
I cannot find an equivalent for the command {{jpa-new-field}}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 1 month
[JBoss JIRA] (FORGE-1396) Singular or Plural ?
by Antonio Goncalves (JIRA)
Antonio Goncalves created FORGE-1396:
----------------------------------------
Summary: Singular or Plural ?
Key: FORGE-1396
URL: https://issues.jboss.org/browse/FORGE-1396
Project: Forge
Issue Type: Sub-task
Components: UI - Shell
Affects Versions: 2.0.0.Beta4
Reporter: Antonio Goncalves
For listing all the services we use the {{services-list}} command. Here, {{services}} is in plural. But if we have several commands related to services, we might end-up with a mixture of singular and plural :
{code}
services-list
service-register-as-serviceloader
{code}
Same thing could happen if we list all add-ons (here I'm supposing that the command {{addons-list}} exits) :
{code}
addons-list
addon-build-and-install
addon-install
addon-new-command
addon-remove
{code}
Is the mixture or plural and singular ok ? Shouldn't it all be in singular :
{code}
addon-list
service-list
{code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 1 month
[JBoss JIRA] (FORGE-1394) Rename bean-validation-setup command
by Antonio Goncalves (JIRA)
Antonio Goncalves created FORGE-1394:
----------------------------------------
Summary: Rename bean-validation-setup command
Key: FORGE-1394
URL: https://issues.jboss.org/browse/FORGE-1394
Project: Forge
Issue Type: Sub-task
Components: UI - Shell
Affects Versions: 2.0.0.Beta4
Reporter: Antonio Goncalves
At the moment, {{setup}} commands are related to the core technology :
{code}
faces-new-converter faces-new-validator faces-new-validator-method faces-setup
jpa-new-entity jpa-new-field jpa-setup
{code}
For Bean Validation, there is a {{bean-validation-setup}} command. But, shouldn't it be {{constraint-setup}} ? Also see [FORGE-1393].
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 1 month
[JBoss JIRA] (FORGE-1393) constraint commands are missing
by Antonio Goncalves (JIRA)
Antonio Goncalves created FORGE-1393:
----------------------------------------
Summary: constraint commands are missing
Key: FORGE-1393
URL: https://issues.jboss.org/browse/FORGE-1393
Project: Forge
Issue Type: Sub-task
Components: UI - Shell
Affects Versions: 2.0.0.Beta4
Reporter: Antonio Goncalves
On Forge 1.x you could add constraints to a specific field with
{code}
constraint NotNull --onProperty login ;
{code}
The {{constraint}} commands are missing. If we follow the new naming convention, we should have, at least, one command to create new custom constraints (that could go into a default {{constraint}} package for example :
{code}
constraint-new MyOwnConstraint ;
{code}
And a command to add a constraint to a property :
{code}
constraint-add NotNull --onProperty login ;
constraint-add MyOwnConstraint --onProperty lastname ;
{code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 1 month