[JBoss JIRA] (FORGE-1569) Forge dialogs do not obtain focus on launch
by George Gastaldi (JIRA)
[ https://issues.jboss.org/browse/FORGE-1569?page=com.atlassian.jira.plugin... ]
George Gastaldi closed FORGE-1569.
----------------------------------
Assignee: Koen Aers
Fix Version/s: 2.12.2.Final
(was: 2.x Future)
Resolution: Done
This was fixed in JBT 4.2.0.Final
> Forge dialogs do not obtain focus on launch
> -------------------------------------------
>
> Key: FORGE-1569
> URL: https://issues.jboss.org/browse/FORGE-1569
> Project: Forge
> Issue Type: Feature Request
> Components: UI - Eclipse
> Affects Versions: 2.0.0.Final
> Environment: Fedora 17, Eclipse Kepler
> Reporter: Vineet Reynolds
> Assignee: Koen Aers
> Priority: Minor
> Fix For: 2.12.2.Final
>
>
> When I launch a new Forge dialog in Eclipse, it does not automatically obtain focus. For a keyboard user, this is slightly frustrating, as this requires Alt-Tabbing back and forth to Eclipse for the dialog to obtain eventually focus.
--
This message was sent by Atlassian JIRA
(v6.3.8#6338)
10 years, 2 months
[JBoss JIRA] (FORGE-1813) Shall we rename webroot to targetDir or something different ?
by George Gastaldi (JIRA)
[ https://issues.jboss.org/browse/FORGE-1813?page=com.atlassian.jira.plugin... ]
George Gastaldi closed FORGE-1813.
----------------------------------
Resolution: Deferred
This should be considered in the next major release
> Shall we rename webroot to targetDir or something different ?
> -------------------------------------------------------------
>
> Key: FORGE-1813
> URL: https://issues.jboss.org/browse/FORGE-1813
> Project: Forge
> Issue Type: Task
> Components: Brainstorming
> Affects Versions: 2.5.0.Final
> Reporter: Antonio Goncalves
> Fix For: 2.x Future
>
>
> In [FORGE-1787] the parameter {{webroot}} seems confusing. Maybe we could change it to targetDir like other command, or something different (as it refer to a subdirectory of web app.
> Read on #IRC
> {code}
> agoncal And what about targetPackage ? What I really want is a --webroot (like the scaffold command) no ?
> lincolnthree agoncal: targetDir ?
> agoncal lincolnthree Hum... it's called --webroot on other places (which is the relative webapp/ directory)
> lincolnthree agoncal: but it's not the webroot dir in this case
> lincolnthree agoncal: it's the target directory where the file will be generated
> gastaldi +1 to targetDir
> lincolnthree agoncal: doesn't have to be in the web root, but could default there
> lincolnthree or even just target
> agoncal lincolnthree But by default it's under /webapp if you don't specify it. If you do (eg. --webroot admin) then the file is generated under /webapp/admin
> agoncal I'm refering to webroot because it looks the same as FORGE-1787
> lincolnthree agoncal: totally different
> agoncal lincolnthree ok
> lincolnthree agoncal: well.. maybe not totally :p
> lincolnthree agoncal: webroot is a bad name for that
> agoncal lincolnthree I'll go for for targetDir
> agoncal lincolnthree Do you want me to create a JIRA about renaming webroot to targetDir ?
> lincolnthree agoncal: why not skip targetDir entirely and just go for —output
> lincolnthree agoncal: yeah we may want to address this
> lincolnthree output would be target dir and filename together
> {code}
--
This message was sent by Atlassian JIRA
(v6.3.8#6338)
10 years, 2 months
[JBoss JIRA] (FORGE-1917) ClasspathWorkspaceResolver no longer works for impl projects
by George Gastaldi (JIRA)
[ https://issues.jboss.org/browse/FORGE-1917?page=com.atlassian.jira.plugin... ]
George Gastaldi closed FORGE-1917.
----------------------------------
Fix Version/s: 2.12.2.Final
(was: 2.x Future)
Resolution: Done
I believe this works now
> ClasspathWorkspaceResolver no longer works for impl projects
> ------------------------------------------------------------
>
> Key: FORGE-1917
> URL: https://issues.jboss.org/browse/FORGE-1917
> Project: Forge
> Issue Type: Bug
> Components: Build Tools - Maven
> Affects Versions: 2.6.0.Final
> Reporter: George Gastaldi
> Fix For: 2.12.2.Final
>
>
> In split projects (api/impl/addon), the tests no longer detect the changes in the workspace.
> This is caused because the classpath for the impl classes is no longer available for tests (impl was made <optional> by default) .
> This requires the user to manually install the api/impl projects before running the tests, which can be cumbersome
--
This message was sent by Atlassian JIRA
(v6.3.8#6338)
10 years, 2 months
[JBoss JIRA] (FORGE-1981) Add a CommandListener interface/extension point (Name TBD)
by George Gastaldi (JIRA)
[ https://issues.jboss.org/browse/FORGE-1981?page=com.atlassian.jira.plugin... ]
George Gastaldi closed FORGE-1981.
----------------------------------
Fix Version/s: (was: 2.x Future)
Resolution: Done
Closing as this looks like it's already implemented
> Add a CommandListener interface/extension point (Name TBD)
> ----------------------------------------------------------
>
> Key: FORGE-1981
> URL: https://issues.jboss.org/browse/FORGE-1981
> Project: Forge
> Issue Type: Feature Request
> Components: UI - API
> Affects Versions: 2.7.2.Final
> Reporter: Lincoln Baxter III
>
> {code}
> Registration<CommandListener> registration = CommandFactory.addCommandListener(myListener);
> {code}
> {code}
> I was thinking of introducing a "onLeaving()" method
> 2:31 or something like that
> lincolnthree
> 2:31 gastaldi: yeah… onNext()
> 2:32 onNextRequested()
> gastaldi
> 2:32 hmmm
> lincolnthree
> 2:32 onFinishRequested()
> gastaldi
> 2:32 yeah
> 2:32 balunasj|mtg [~balunasj(a)pool-108-12-26-94.syrcny.fios.verizon.net] entered the room.
> gastaldi
> 2:33 maybe in the UICommand interface
> 2:33 or create another interface for that, not sure
> lincolnthree
> 2:36 gastaldi: i think another interface could work
> 2:36 gastaldi: actuallllyyyyy
> 2:36 gastaldi: UIEventListener
> gastaldi
> lincolnthree
> 2:36 gastaldi: commands that implement this interface could automatically be registered as listeners for the duration of their execution!
> 2:37 gastaldi: but you could also register global ones on the factory
> lincolnthree
> 2:37 Registration<CommandListener> registration = CommandFactory.addCommandListener(myListener);
> 2:38 the CommandController could simply do that for commands that implement the interface, then automatically remove the listener when the command is aborted/finished
> 2:38 CommandController could implement it and delegate to the command
> 2:39 because the UI provider implementation knows when to proceed to the next page
> 2:40 well, I think CommandController should work too
> lincolnthree
> 2:40 I think CommandController would work
> {code}
--
This message was sent by Atlassian JIRA
(v6.3.8#6338)
10 years, 2 months
[JBoss JIRA] (FORGE-2077) Batch mode should process keyboard input
by George Gastaldi (JIRA)
[ https://issues.jboss.org/browse/FORGE-2077?page=com.atlassian.jira.plugin... ]
George Gastaldi commented on FORGE-2077:
----------------------------------------
I think the subject of this issue should be "Script execution should allow keyboard input". Batch mode is really the opposite of input from user
> Batch mode should process keyboard input
> ----------------------------------------
>
> Key: FORGE-2077
> URL: https://issues.jboss.org/browse/FORGE-2077
> Project: Forge
> Issue Type: Bug
> Reporter: Ondrej Zizka
>
> STR:
> 1) Download Windup 2
> 2) Run bin/windup.sh -e "man windup-migrate-app"
> Now you're stuck :)
> Forge should process keyboard input somehow. Maybe just for some actions? Or, user should have an option whether to read from stdin or keyboard?
--
This message was sent by Atlassian JIRA
(v6.3.8#6338)
10 years, 2 months