Hi there,

A few things that will hopefully clear up these issues :)

The Errai plugin is for Forge 2. It won't work in Forge 1.

Based on the Forge 2 output you pasted, it looks like you were trying to run `forge --install xxxxxx` from within Forge shell itself. This command must be run from your system terminal, outside of Forge 2. To install addons within Forge, you can use the: `addon-install` command.

Also, a hint: Press <TAB> to see a list of available commands within Forge 2.

Cheers!


On Mon, Mar 3, 2014 at 6:42 AM, <forge-users@lists.jboss.org> wrote:
Hi

I'm a first time user of forge, so please forgive me if these seem like stupid questions.

I've wanting to use forge as it seems like it will speed update development, especially of erria applications.

I installed Forge, as documented on errai/forge-errai GitHub (https://github.com/errai/forge-errai) and https://github.com/forge/core#jboss-forge-20

Firstly, I tried installing it into JBDS. According to the documentation I should be able to hit ctrl-5 and the Forge UI should show. This did not happen.

I tried the eclipse console, and tried to add the errai plugin.

Wrote /home/anton/.forge/httpsrawgithubcomforgepluginrepositorymasterrepositoryyaml.yaml
[magick.watcher] dev $ forge install-plugin errai
***INFO*** Preparing to install plugin: errai
***INFO*** Checking out plugin source files to [/tmp/forgetemp6427039614160685695] via 'git'
***INFO*** Switching to branch/tag [refs/heads/master]
***INFO*** Cleaning up temp workspace [/tmp/forgetemp6427039614160685695]
Deleted /tmp/forgetemp6427039614160685695
***ERROR*** Exception encountered: The project does not contain a valid Forge Plugin project. Installation aborted (type "set VERBOSE true" to enable stack traces)




_____
| ___|__ _ __ __ _ ___
| |_ / _ \| `__/ _` |/ _ \ \\
| _| (_) | | | (_| | __/ //
|_| \___/|_| \__, |\___|
|___/


JBoss Forge, version [ 2.1.1.Final ] - JBoss, by Red Hat, Inc. [ http://forge.jboss.org ]


[bin]$ forge
***ERROR*** No such command: forge
[bin]$ forge Project: New
***ERROR*** No such command: forge
[bin]$ forge --install core
***ERROR*** No such command: forge
[bin]$ forge --install shell
***ERROR*** No such command: forge
[bin]$

I am obviously doing something very wrong. Can someone please help me?
I would preferably use the UI in eclipse, but am fine with using the command line. Unfortunately neither is working.

Posted by forums
Original post: https://community.jboss.org/message/860448#860448

_______________________________________________
forge-users mailing list
forge-users@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/forge-users



--
Lincoln Baxter, III
http://ocpsoft.org
"Simpler is better."