gatein_wsrp_trunk_sun5 #110: Still Failing
No tests ran.
No tests ran.
Changes for Build #100
[chris.laprun(a)jboss.com] - Minor.
Changes for Build #101
[chris.laprun(a)jboss.com] - GNTWSRP-42, GTNWSRP-43: done for GetResource, HandleEvents and
PerformBlockingInteraction, forcing setting of RegistrationContext and UserContext since
the WSRP xsd specifies that they are required, albeit nillable.
- Renamed createResourceRequest and createMarkupRequest to createGetResource and
createGetMarkup for better consistency.
- Removed unused createDefaultResourceRequest method.
[chris.laprun(a)jboss.com] - GNTWSRP-42, GTNWSRP-43: done for GetServiceDescription, forcing
setting of RegistrationContext and UserContext since the WSRP xsd specifies that they are
required, albeit nillable.
- GTNWSRP-37: properly transmit requested portlet handles for service description
filtering to producer.
[chris.laprun(a)jboss.com] - GTNWSRP-59: for now, assume that if we've got char content,
it needs to be rewritten. Cleaned-up WSRPResourceURL and adapted test cases.
[chris.laprun(a)jboss.com] - GTNWSRP-37: Implemented POP filtering and added test cases.
Changes for Build #102
Changes for Build #103
[chris.laprun(a)jboss.com] - Minor clean-up.
[chris.laprun(a)jboss.com] - GTNWSRP-63: PortletManagementHandler now properly produces an
InconsistentParameters exception when needed & added test case.
- Fixed BasicPortletManagementBehavior to be more useful in checking errors instead of
magically producing expected output.
- Reactivated commented-out tests in PortletManagementTestCase (v1 & v2) on the
consumer side and added test for proper handling of case when we try to set/reset a
property in the same call.
- Fixed converters which weren't properly dealing with ResetProperties.
- WSRPConsumerImpl.getProperties should now behave more precisely in case of producer
error.
Changes for Build #104
[chris.laprun(a)jboss.com] - Changed handling of null portlet handles as a null portlet
handle is not an InvalidHandle since the handle is a non-nillable element at the XML
level so should result in an OperationFailed exception and updated test cases
accordingly.
- Replaced use of NotYetImplementedException by NotYetImplemented (that added an undesired
dependency on org.jboss.messaging)
- Fixed more typos and removed use of ExtendedAssert where unneeded.
[chris.laprun(a)jboss.com] - Fixed typos and other minor improvements.
- GTNWSRP-43: Removed direct call to PortletContext constructor.
Changes for Build #105
[mvanco(a)REDHAT.COM] WSRP sample portets:
- added copyrights at java classes and edited code conventions
[mvanco(a)REDHAT.COM] WSRP2 sample test portlets + 2 unit tests at wsrp-producer-war
(MarkupTestCase)
- tests verify eventing between 2 portlets, one test is using sample event (with String
value), another one is using TestObject
- test testGetMarkupWithEventsAndObjects reproduces error:
javax.xml.ws.soap.SOAPFaultException: Couldn't marshall payload TestObject with
expected type {##default}##default
- simple portlets contain these features: events, events with object, portlet modes
- added assembly descriptors to generate separate war archives
Changes for Build #106
[chris.laprun(a)jboss.com] - Fixed improper test. Should now pass.
[mwringe] GTNWSRP-46: Update wsrp test setup to handle portlet tlds.
[mvanco(a)REDHAT.COM] WSRP2 Sample portlets
- edited formatting and headers of java files
- added new sample test portlet - public render parameter
- added descriptor for creating separate jar archive with TestObject (this archive should
be put at consumer side when testing events with complex types - more info will be at
GTNWSRP-67)
[chris.laprun(a)jboss.com] - Minor output formatting so that state is better seen.
[chris.laprun(a)jboss.com] - Comment out testGetMarkupWithEventsAndObjects as it's not
currently possible to recreate a complex event object on the consumer. See GTNWSRP-67.
- Re-formatted.
[chris.laprun(a)jboss.com] - Re-formatted and fixed copyright.
[chris.laprun(a)jboss.com] - GTNWSRP-66: Do not use the annotation information to get type
information as if no information is given to the annotation, this will result in ##default
and an improprer value to be serialized.
Changes for Build #107
[mvanco(a)REDHAT.COM] WSRP2 Sample portlets
- added new tests for prp, portlet modes (default + custom) - all of them are passing
now
- edited test for events with object to have same structure as test for simple events
Changes for Build #108
[mwringe] GTNWSRP-43: update calls to WSRP 2 type constructors to use the WSRPTypeFactory
instead of directly.
GTNWSRP-42: update WSRPTypeFactory to be conform to the xsd.
Changes for Build #109
[chris.laprun(a)jboss.com] - GTNWSRP-68: added test case.
[chris.laprun(a)jboss.com] - Changed name of environment variable from JBOSS_TEST_HOME to
JBOSS_5_1_0_HOME for the clean AS version to use in tests to align with PC tests, thus
making it easier for people. Thanks, theute! :)
[chris.laprun(a)jboss.com] - If no ExportManager has been set, use the default one.
[chris.laprun(a)jboss.com] - Moved ExportManager accessors to WSRPProducer as the
integration in GateIn doesn't distinguish between both versions and the WSRP 1
producer actually delegates to the WSRP 2 version so it needs to be properly configured.
[chris.laprun(a)jboss.com] - Fixed exception handling.
[chris.laprun(a)jboss.com] - GTNWSRP-61: Added primitive export capability to admin GUI.
Still needs work, obviously! :)
- Added MigrationService and ExportInfo to manage exported data over time.
[chris.laprun(a)jboss.com] - Added new option to be able to only deploy the admin gui
portlet to AS deploy directory. Requires removing wsrp-admin-gui.war from gatein.ear and
application.xml.
[chris.laprun(a)jboss.com] - GTNWSRP-68: Only check for NS inconsistency if the NS is either
WSRP 1 or WSRP 2. Ignore ports with unknown namespaces.
- Fixed typo.
Changes for Build #110
[mwringe] GTNWSRP-64: remove lifetime class references (WSRP 2.0 specific class) in the
export manager apis. Still need to throw new, non WSRP 2.0 specific exceptions. Ugly right
now, still need to find a better more clean solution.
GTNWSRP-69: Update the persistence manager classes to work a bit better. The
TestMockExportPersistenceManager is very close to being an in memory solution.
[chris.laprun(a)jboss.com] - GTNWSRP-61: improved many aspects of the UI
+ now require a consumer refresh to see import/export actions since we need to check
that the operation is available first
+ implemented export list view
+ started adding implementations for export list actions
+ added ExportInfoDisplay and FailedPortletsDisplay classes to better control how an
ExportInfo is displayed
- Added getHumanReadable* methods on ExportInfo to display times in human readable
format.
- Added WSRPConsumer.isSupportsExport method to determine whether a given consumer
supports import/export (right now, only checks protocol version)
[chris.laprun(a)jboss.com] - Minor reformatting.
[chris.laprun(a)jboss.com] - GTNWSRP-61: Again, not sure what's going on... :(
[chris.laprun(a)jboss.com] - GTNWSRP-61: Fixed weird issues with spaces.
Public URL:
https://hudson.jboss.org/hudson/job/gatein_wsrp_trunk_sun5/110
Private URL:
http://hudson.qa.jboss.com/hudson/job/gatein_wsrp_trunk_sun5/110/