On Mar 20, 2015, at 12:23 PM, Lukas Krejci <lkrejci@redhat.com> wrote:

On Friday, March 20, 2015 09:03:19 mike thompson wrote:
On 20 Mar 2015, at 08:19, Lukas Krejci <lkrejci@redhat.com> wrote:

I think the "metrics" should actually be dropped instead of "numeric”.

The only thing about ‘numeric’ is that it is not very specific. Numeric just
means number — every metric is a number so its really not adding anything.
Even availability data is numeric.

Isn't metrics going to store "events" eventually, too? Those would be textual,
wouldn't they?

Also, IMHO, even config could be stored in metrics. Even though that is a bit
of a stretch, configuration is after all a time series of structured data...

You're right that at the moment numeric doesn't add much information. So maybe
instead of that, the type would specify what should be done with the metric?

Something along the lines of dropwizard-metrics' distinction between a meter,
counter, gauge, histogram, etc?

So like:

http://asdf.com/hawkular/metrics/tenant1/histogram/{id}
http://asdf.com/hawkular/metrics/tenant1/counter/{id}


My aggregate metrics design doc[1] talks about formally introducing gauges and counters. The question I have about endpoints like this is what about pushing a batch of metrics? Do we need to make a separate request for each type? That seems cumbersome and inefficient.

[1] http://bit.ly/1BAfF8d


Hawk metrics will never deal with anything else than some kind of metric,
so way have it in the path? On the other hand having the type of the
metric in the path is IMHO more useful.

It is the context root of the metrics rest web app that should be called
"metrics", IMHO.

So the paths in metrics would look like:

/{tenantId}/numeric/data
/{tenantId}/availability/data

and the REST API user would reach those on the URLs like:

http://asdf.com/hawkular/metrics/tenant1/numeric/{id}/data

conversely, inventory could be reached on the same host like:

http://asdf.com/hawkular/inventory/tenant1/production/resources/{id}

On Friday, March 20, 2015 11:00:22 John Sanda wrote:
There has been some good discussion around availability lately. I want to
add one more to the mix, but hopefully this one is not as in-depth as
some
of the other topics. Right in metrics we have endpoints like,

POST   /metrics/numeric/data
GET     /metrics/numeric/{id}/data
POST  /metrics/availability/data
GET    /metrics/availability/{id}/data

I would like to change these to,

POST   /metrics/data
GET     /metrics/{id}/data
POST  /availability/data
GET    /availability/{id}/data

I think the “metrics” prefix is awkward and unnecessary. I think that it
is
intuitive enough that metrics on its own refers to numeric data.
Thoughts?


- John
_______________________________________________
hawkular-dev mailing list
hawkular-dev@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/hawkular-dev

_______________________________________________
hawkular-dev mailing list
hawkular-dev@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/hawkular-dev


_______________________________________________
hawkular-dev mailing list
hawkular-dev@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/hawkular-dev